0

Website: www.Bean2Bed.com Magento ver. 1.5.1.0

I'm not very web savvy so please bear with me. We use Google Apps for Business to handle our email, so have an email address Sales@(TheDomainMentionedAbove.com). For about 3 weeks now, we've stopped receiving all mails from the website, i.e.:

1) Contact Form submissions (http://bean2bed.com/contact) - if a customer fills it in and presses Submit, it will say data submitted, but we've stopped receiving the email from Sales@ with the data they've submitted.

2) Emails notifying of a new order placed and paid for on the site. We have to keep logging into Magento to check on new orders. Before both ourselves (Sales@) and the customer would get an email showing what they've ordered, and the email would also come from Sales@.

We haven't made any changes to the website or back end in the last few months, so for it to stop working is quite strange.

We've contacted Titan Internet who host our domain, and they have said it could be that the Contact Form is configured incorrectly because the sender email address should be Sales@ but it is actually being sent from bean2bed@electra-1.titaninternet.co.uk. Apparently we need to check the contact and ensure that 'localhost' is not set on the form.

Can someone please explain what this means? I have searched through this forum and found where to go to in Magento to change the from address (System > Configuration, etc.) but they all say Sales@ already. I can't find this bean2bed@electra-1.titaninternet.co.uk address anywhere to be able to change it.

I have logged into the ftp as well, downloaded a whole bunch of files, opened each one with Notepad to see if any of them contain that email address, and I still haven't found one.

I read something here (https://stackoverflow.com/questions/15036413/why-isnt-google-apps-email-address-receiving-email-from-magento-website/15038847#15038847) about how you need to switch off the mailserver for that domain. I'm not sure if this is the same issue, or where I need to go to to do that, and whether it would affect any of our normal mail coming to Sales@ (which works fine by the way).

Can someone please help?!

2

What hosting control panel are you using?

As you are using Google Apps for emailing, you need to make sure that emails that are sent from your Magento installation is delivered to your Google Apps mail server and not to the local mail server.

The way to do this differs from one hosting control panel to another:-

1. cPanel

Go to cPanel --> MX Entry --> Email Routing.

Change it to Remote Mail Exchanger.

2. Plesk

Go to Domains --> Open in control panel --> Mail --> Change settings.

Uncheck the box next to Activate mail service on domain.

If the above ways still doesn't resolve the issue, you need to have your hosting provider trace on why the emails are still being delivered locally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.