2

The issue is when i enabled solr (i successfully configured solr and tested successfully) in magento enterprise,the layered navigation filter is not working properly.

i.e displaying all category products not filter with attributes value.

If i set "No" in Enable Solr Engine for Catalog Navigation in admin panel it's working fine.

Path -> System -> Configuration -> Catalog -> Catalog Search -> Enable Solr Engine for Catalog Navigation -> set to "No"

I analysed magento enterprise search module,but they not adding custom attributes into solr params.like attr_nav_select_"custom_attribute"

ex : http://localhost.com:8080/solr/test/select/?q=wine%0D%0A&version=2.2&start=0&rows=10&indent=onq=test&qt=magento_en&fq=
%28visibility:3+OR+visibility:4%29+AND+store_id:13+AND+in_stock:true

Any one tell me is this magento issue or i need to configure any other matter.

Anything i would appreciate.Thanks in advance.

1 Answer 1

2

Finally i found the solution.i update in catalog.xml under <catalog_category_layered>

    <reference name="left">
        <block type="catalog/layer_view" name="catalog.leftnav" before="-" template="catalog/layer/view.phtml"/>
    </reference>

changed to

    <reference name="left">
<block type="enterprise_search/catalog_layer_view" name="catalog.leftnav" before="-" template="catalog/layer/view.phtml"/>
    </reference>

now i am getting attribute values in solr params like "attr_nav_select_brand:13"

http://localhost.com:8080/solr/test/select/?q=test&qt=magento_en&fq=(visibility:3+OR+visibility:4)+AND+(attr_nav_select_brand:13)+AND+store_id:3+AND+in_stock:true

but i don't know how to pass multiple values for specific attribute.any one guide me or suggest me how to make URL for multiple values for attribute.in default magento working with single value for attribute.

the category url like

http://localhost.com/whiskies.html?brand=Dreamer&mode=list&pack_size_in_litres=2+litres
3
  • Please close the issue as well. Leaving answered issues open is bad for the site as whole.
    – Pronto
    Nov 7, 2014 at 22:53
  • This is timely for me as I'm working on the same issue. Any luck here?
    – philwinkle
    Nov 11, 2014 at 5:34
  • Hi philwinkle, it working with single value for attributes like "attr_nav_select_brand:13" if you want multi values for attributes please use any third party plugin.like magentocommerce.com/magento-connect/…
    – raheem.unr
    Nov 12, 2014 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.