0

Recently upgraded from 1.7 to the latest version (1.9) of CE.

Having a problem with a catalog price rule - and it's the first rule I've set up since the upgrade.

The rule is set up to be 10% off all products from a particular brand. Very simple. Priority is zero and have it set to stop processing after this rule. There are other rules set as 'active' but they're all expired.

When I make this rule active and apply it, the discount shown on the front end is much larger than 10%, it's more like 30%.

And if I apply a discount of 0%, the items all show a discount of around 10%.

I'm not sure if the rule is getting applied multiple times, or there are deleted rules that are being applied in correctly.

  • Are the expired rules active? If so, set the as inactive. This should help determine if the are still being applied. Also line items in cart will hold a list of applied rule ids. In the cart output the value of ->getAppliedRuleIds() to see what rules applied to the item – ProxiBlue Oct 24 '14 at 0:05
  • So... Deleting the old rules fixed my problem, just marking them as inactive did not. Odd. – SamC Oct 24 '14 at 2:16
0

I moved my comments to answer, so this question can be shown as having an answer, as it seems solved.

You need to definitively determine if those old rules are causing the problem.

Are the expired rules active?

If so, set them as inactive. This should help determine if they are still being applied.

Also line items in cart will hold a list of applied rule ids. In the cart output the value of ->getAppliedRuleIds() to see what rules applied to the item

As per your comment above, deleting those rules fixed the problem. All good and well, but if I were you I'd do a new test, to determine if this is just an upgrade issue (old rules not working/compatible to site db/code changes), or if you have an underlying issue with your site.

Create a new rule, marked it as expired - test if it also applies. Mark it as inactive - test if it also applies.

If they do, you need to dig a bit further, as something is not right, and you'd run into issues later (and forget about this issue possible) It could also potentially point to other issues after the upgrade.

Nothing worse than having strange inconsistencies 6 months down the line, and not knowing why....

0

If your using 1.9.0.X then it is a recognised bug, the rules do not expire properly if you have old rules set up for the same products/discounts then they will be multiplied.

This has been fixed in 1.9.1 see release notes here: http://www.magentocommerce.com/knowledge-base/entry/ce19-later-release-notes#ce19-1910

It resolves a number of issues:

  • Catalog Price Rule Fixes
  • Catalog price rule expiration dates are observed.
  • The database and prices update properly when catalog price rules are created or edited.
  • Catalog price rules apply to customer groups properly. Resolved intermittent issues applying catalog price rules.
  • Later I ran into rules that were set in the future, which were being applied to a current sale. I'm not sure if it goes both ways (past & future rules), but it wouldn't surprise me if that were the case. I'll do some testing and see what happens. Thanks for pointing this out, it's worth looking into. – SamC Dec 1 '14 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.