0

In Magento CE 1.9.0.0 I have the problem that when I add a downloadable product in backend and want to add the file by clicking "Add new row" nothing happens.

The console reports:

SyntaxError: unterminated string literal 'Dieser Inhalt erfordert die neueste Version des Adobe Flash

Does someone know in which file the error occurs?

2
  • What browser are you using? Are you using ssl or self signed certificate? Also see helpx.adobe.com/de/flash-player/kb/… Oct 21 '14 at 13:47
  • I havet tested it in Firefox, Chrome and IE without SSL or certificates. It seems that there is somewhere a linebreak that produces this error because this line 'Dieser Inhalt erfordert die neueste Version des Adobe Flash Players. <a href="adobe.com/go/getflash/">Flash herunterladen</a> has no '+ at the end Oct 21 '14 at 13:55
2

The file uploader uses flash, please make sure you have an up to date version of flash installed for your browser.

3
  • Yes, if I test the same procedure in CE 1.9.0.1 everything works fine Oct 21 '14 at 13:15
  • Does this happen on a clean install without any extensions or customisations? Oct 21 '14 at 13:25
  • Yes, it is a clean install Oct 21 '14 at 13:38
0

The root cause for this problem is the file app/locale/de_DE/Mage_Media.csv which somehow contains an additional line break at the end of the file:

"This content requires last version of Adobe Flash Player. Get Flash","Dieser Inhalt erfordert die neueste Version des Adobe Flash Players. Flash herunterladen 
"

Of course this can easily be fixed by removing additional line break or adding a translate.csv to your admin theme and adding the line

"Mage_Media::This content requires last version of Adobe Flash Player. Get Flash","Dieser Inhalt erfordert die neueste Version des Adobe Flash Players. Flash herunterladen"
3
  • @ ramesh : Did you know about stackoverflow.com/questions/33429277/… this error solution
    – Gem
    Apr 11 '17 at 10:18
  • @JeevaRathinam : Yes, I know. May be you are missing weight. You may trace feedex response and url here in /app/code/core/Mage/Usa/Model/Shipping/Carrier/Fedex.php Note :- Please don't do any permanent changes in base file Apr 11 '17 at 12:24
  • @ Ramesh Kumar : join chat.stackexchange.com/rooms/56921/…, i am post all the details
    – Gem
    Apr 12 '17 at 6:03
0

After searching for the answer I came across a hint that was the solution. The Problem is probably caused by a language file:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.