I’ve installed magento community edition version and have found that when I set the new captcha feature under System>Configuration>Customer>Customer Configuration>CAPTCHA

I set the captcha to be used on create user and forgot password forms. Tested Create New Account form on frontend and found that the captcha box does not appear at all but when you fill in the form and submit and error message comes back saying that "incorrect captcha".

Its looking for the captcha but not allowing it to be visible for me to fill box in?

Where do I go to make captcha visible in frontend?

I did delete cache and cleared sessions and logged out and logged back in, just not there.

  • check the css like it will hide or not ?
    – Keyul Shah
    Oct 21, 2014 at 5:48
  • Yes, I have checked it, and css is not hiding it... Oct 21, 2014 at 5:53
  • getting some JS error in console?
    – Keyul Shah
    Oct 21, 2014 at 5:55
  • No, Not getting JS error as well Oct 21, 2014 at 6:04
  • then It will may conflict with theme please change to default them and test
    – Keyul Shah
    Oct 21, 2014 at 6:43

3 Answers 3


Sadly the RWD theme has been implemented without captcha. See notes from the design guide section Exceptions to Responsive Web Design.

They have managed this by providing an empty layout.xml file for the captcha module under app/design/frontend/rwd/default/layout/captcha.xml. What you could try is to disable this file and so it will fall back to the default captach.xml and see if this works.

Sadly I have not tried this as yet.

  • Thanks buddy... That worked :) Oct 21, 2014 at 7:39
  • @HarishKumar glad that it worked, not sure if this will have any side issues as the design is very different. Oct 21, 2014 at 7:40

Check disk space from your server. After you free some space, you will need to reboot and check again.


It worked for all.

I renamed the file captcha.xml to something else and it worked.

  1. I tried magecomp and was of no use as you register with them and they let you download a tar file that with no instructions. Waste of time.
  2. I tried amasty too with no luck.

All i did was rename the captcha file and flush the cache. Thats important. Then i enabled the captcha in system>configuration>customer configuration. I used to get a lot of bot registrations and the spam registrations from ru sites have stopped.

Captcha issue solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.