5

I followed below steps to show captcha in login and registration form. But I can't see it.

  1. Login to backend
  2. Go to system > configuration > customers > customer configuration > CAPTCHA and select your website scope
  3. Enable CAPTCHA on frontend - Yes
  4. Select all forms into "Form" box
  5. In "Displaying Mode" box select "After number of attempts to login"
  6. Number of Unsuccessful Attempts to Login = 0
  7. Save Config
  8. Go to frontend and press "Log in" link

Is there any thing else left to enable captcha in login or registration form...

6

Sadly the RWD theme has been implemented without captcha. So you can customize theme. Follow these steps:

  1. Go Base theme/layout folder and copy the captcha.xml file code in your theme directory/layout/captcha.xml file in layout folder.
  2. Go Base theme/template and copy the captcha directory and paste in your theme/template folder.

Thus, your captcha code will be visible.

  • 1
    Did as u said but still it is not showing up – Wasiq Shahrukh Jan 24 '17 at 13:18
2

I followed this tutorial to enable Captcha for my Magento store: http://magentoexplorer.com/how-to-enable-captcha-in-magento

To enable Captcha for front end

Magento has built-in captcha for Frontend, you can enable it by navigating to System > Configuration > Customers > Customer Cunfiguration, Next, Select Yes for field Enable CAPTCHA on Frontend. There are a number of options here for frontend CAPTCHA. enter image description here

Enable CAPTCHA for Backend

To enable CAPTCHA for backend, you can navigate to System -> Configuration -> Advanced section -> Admin -> CAPTCHA

Enable CAPTCHA for contact page Use this free module Download the module

magentocommerce.com/magento-connect/contacts-form-captcha.html

Not the answer you're looking for? Browse other questions tagged or ask your own question.