7

After successfully running composer install under the setup directory and then calling 127.0.0.1:8080/setup in my browser, the Magento Installer runs and I am able to successfully complete the first five config steps without error, including locally verifying the mysql db params. Everything reports normally and without error.

Step 6, where you actually run the installer, not so much.

The installer quits/hangs at 0% Complete and reports that the installation is incomplete and to check the console log for the errors.

The console log is empty of any comment relating to magento, php, http issues.

Further, the buttons for previous and try again are both disabled. I can reload the setup and re-complete the setup process, but it hangs in the same spot each time. I am nothing if not persistent.

Curious if anyone else has experienced a crash at this step and if so, how you resolved it.

I confess I'm stumped by the lack of log data.

14

Please add the following code to your .htaccess

php_value xdebug.max_nesting_level 500

See More on - Bhupendrajadeja.com/blog

3

Looks like web installer tools in active development. Try use console installer php dev/shell/install.php

  • Turns out the installer thinks mcrypt is missing, even though it is not. It's present in php.ini and php -i | grep mcrypt shows it successfully loaded and is active. Probably have to head over to stack overflow for some straight up php advice. Not sure what to do with this right now. – Dave G Oct 17 '14 at 5:16
  • Dave, you said mcrypt shows in PHP CLI info, but maybe mcrypt is missing for your web server PHP? – Wojtek Naruniec Dec 16 '14 at 6:25
2

Add ini_set('xdebug.max_nesting_level', 200); in your index.php file of setup folder.

you can see more details from https://github.com/magento/magento2/issues/815

1

Hi I had the same issue when installing the latest version of magento - it was stuck at 0% and the consol log had no errors.

I remembered I had a similar problem before with a Magento 1.9 version and to fix this I went into my server and increased the PHP memory_limit inside PHP Configuration Editor (running a WHM service) from 32M to 128M for install. This solved the problem and worked fine. I then decreased the memory_limit down to 64M and monitor this when editing modules, installations and mass uploads/configurations. Hope that helps anyone with a similar issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.