I'm trying to change the template used by fishpig to use a custom wp-2columns-left.phtml template.

I've tried updating my theme's local.xml file with:

    <reference name="root">
          <action method="setTemplate"><template>page/wp-2columns-left.phtml</template></action>

I've also tried amending the wordpress.xml to use the same template but it doesn't work either.

I thought that maybe the wordpress_default layout handle was incorrect but I tested it by removing some js from the head and found it worked.

    <reference name="head">
        <action method="removeItem"><type>js</type><script>fishpig/wordpress/search.js</script></action>

Am I missing something? Could something else be overwriting this layout xml? In my theme only wordpress.xml & local.xml are using the wordpress_default handle.

I'm using the ultimo magento theme and the cache is disabled.

  • Please try flushing the cache... it seems to be the caching issue – Dexter Oct 14 '14 at 12:10
  • @Dexter caching was disabled, I flushed the cache anyway but no change :( – Holly Oct 14 '14 at 12:19
  • The code you used to change template layout is correct... moreover you can give a try setting the template code in wordpress.xml – Dexter Oct 14 '14 at 12:30

Did you try to change the default layout template via backend? Wordpress > settings > Template

It is saved in your DB under the core_config table.

To control the layout via XML you need to select -- Default template -- and this will read the value in your XML file

  • I tried this but if I select the -- Default -- Template it uses the template selected in the Default field. If I set the Default field to -- Default -- template, no template is loaded. I think this must be what is overriding to local.xml though – Holly Oct 14 '14 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.