2

I am having some issues with my Magento site. I have 2 backend guys on it and they cant get to the bottom of it.

It started off with this error this morning

Error: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

When a customer has enters their delivery/payment details and clicks complete the order it hangs for 1-2 minutes and then returns the above error.

We figured out that if a customer pays with paypal it goes through perfectly. Also with some credit card transactions, we noticed that some go through but we still get the above error.

We have increased max_allowed_packet and query_cache_size

Any help would be greatly appreciated asIi am not a techie and my techies can't figure it out

Magento 1.9, Onestepcheckout

(max_allowed_packet is not the issue here)

  • Are you hosting your site on your own server, or do you have a hosting provider? Have you contacted whoemever is responsible for your server and asked them to check up on the MySQL server, and your website's connection to the MySQL server? – Joshua S Warren Oct 13 '14 at 16:59
  • we host it on a shared cloud rackspace server - no i havent, the rest of the site works fine apart from that issue – fabmol Oct 13 '14 at 17:00
  • Is the database running on the same 'server' as the website? i.e., the database connection is to 'localhost'? Also, which service level are you on with Rackspace - is there a chance they've 'secured' your site/server for you? I've seen them be a bit too aggressive with that at times. – Joshua S Warren Oct 13 '14 at 17:03
  • its on a different 'server'. we are on min service level which is no use at all. they havent touched anything on the site – fabmol Oct 13 '14 at 17:10
  • Tried ping between server and database: 8 packets transmitted, 8 received, 0% packet loss, time 7168ms – fabmol Oct 13 '14 at 17:12
2

This could be a few different causes:

  • MySQL server could be configured with a low wait_timeout setting - this would be odd though, because you're saying this happens within 1-2 minutes, and the default for wait_timeout is generally in hours, not minutes.
  • Magento is sending too large of a packet or query - but you've increased max_allowed_packet, so that's unlikely. It would also be odd to have an order exceed max_allowed_packet.
  • There is a networking (packet loss, firewall, etc) issue between your website and the MySQL database server. That usually only crops up on shared hosting (overloaded/oversubscribed or incorrectly configured database server on a different machine than your account) or on elaborate cluster configurations with multiple servers.
  • in 2.5 years i have never seen this issue. thats why i find it weird. As i said if paypal is selected it works fine. We have tried doing a $0 transaction with no credit card required and it crashes also – fabmol Oct 13 '14 at 17:06
  • Do you have a one step checkout extension installed? Do your products have a lot of options the user selects from? Are you seeing any issues with your indexers (in your Magento admin panel, check System -> Index Management). Basically - it sounds like you have a database issue that's cropped up suddenly, but if you haven't changed anything on the site, there has to be another cause. It could be that a specific table has crashed, or grown too large, or that Rackspace did change something (i.e., upgraded MySQL versions, etc). – Joshua S Warren Oct 13 '14 at 17:39
  • yep we use onestepcheckout. We have about 7 options each. Check them out at funkychritmasjumpers.co.uk regarding indexes nothing unusual. But we did have an issue last week where all the configurable products lost association with their child products. IT was after we deleted a store on the server. There was an issue with it. but it was sorted. – fabmol Oct 13 '14 at 17:45
  • It sounds more likely that the query is being killed by another query. This can happen if a reindex is started in the admin (even a product save if indexes are on auto), when an order is being placed. Change all your indexes to manual, apart from stock and price, then remove access to the index management page using admin ACLs and see if your issue persists. – Ben Lessani - Sonassi Oct 14 '14 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.