2

This question already has an answer here:

I installed Magento 1.9.0.0 community today.

I could not install Magento with the permissions I set reading the install guide.

(First the pictures did not show up on the install page due to permission problems, then the "continue" button would not click due to the permissions on the js directory)

I changed the permissions on the directories and files of: js, media, skin, var to 777. What should the permissions be? (I have 700 for directories and 600 for files of all other directories and files).

Then the install worked but got the

"Response from server is invalid"

and had to click:

"Skip Base URL Validation Before the Next Step"

to continue.

I finished the install and every single page I go to gives me a 404 not found error.

Except the index.php.

Check out my page for your self

ifiluv.com

ifiluv.com/admin (does not work)

however adding ifiluv.com/index.php/admin

seems to work.

Also in the configuration changing

Use Web Server Rewrites : to NO

fixes a lot of the links and they work but they don't all work (like ifiluv.com/admin.

So I turned Web Server Rewrites back to YES. I read its bad to turn this off anyways.

Please Help! :*(

marked as duplicate by Fiasco Labs, Keyul Shah, Rajeev K Tomy, Marius, TBI Infotech Oct 13 '14 at 4:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I could not find the answer to this in the search. Im on mavericks with apple. mavericks hides .htaccess files. So I never uploaded the .htacess file. Uploading the hidden .htaccess file fixed the problem. – Travis Oct 14 '14 at 2:53
5
  1. Is this installed on an Apache webserver? If not, the .htaccess functions will need to be translated to your flavor of web server software.
  2. Has DSO module for mod_rewrite been installed in Apache and been enabled to load?
  3. Is AllowOverrides enabled for the virtual server so Options +FollowSymLinks will function? You may have to check with your hosting service provider and have it enabled.
  4. Is Magento's .htaccess file available in the doc root folder?
  5. Has the rewrite engine been turned on in the .htaccess file?
  6. Has the proper RewriteBase been assigned in the .htaccess file?

General entries in Magento's .htaccess that must function so rewrites will function to eliminate the need for index.php to appear in the URL.

<IfModule mod_rewrite.c>
############################################
## enable rewrites
    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root
    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders
    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php
    RewriteRule .* index.php [L]

</IfModule>
  • worked for me: forgot .htaccess while moving the site from a server to another. – nicolallias Jul 11 '17 at 12:51
  • Awesome checklist and also for those who want to make sure #3 AllowOverrides then check this link for Ubuntu stackoverflow.com/questions/18740419/… – Bharath Nov 7 '17 at 13:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.