0

In Configuration/General/Content Management, Enable WYSIWYG Editor is set as "Disabled by Default". And Use Static URLs for Media Content in WYSIWYG for Catalog is set as "No".

Everywhere in the admin panel (products, categories, pages..) the WYSIWYG Editor it's not working properly.

For example, if I go to a Product edit page to set the Description, all the HTML tags appear, and under the textarea it appears the button "WYSIWYG Editor". If I click it, it appears a Pop'up with the buttons "Show / Hide Editor" and Insert Image buttons at the top, and the text contains HTML elements.

See these images:

http://postimg.org/image/4831xzinl/

http://postimg.org/image/6pmkszjzb/

EDIT

For those who don't understand what I'm talking about: The editor worked before and now it doesn't work anymore! If I choose "Enabled by Default" / "Disabled by Default" the editor still does not apper. I haven't changed the core files. I thought that someone might know what can be the problem, but i can see that no one is able to post an answer (excepting Marius).

FIXED

The problem was that the hosting company removed some magento core files because "they contained viruses".. :) Some js files were deleted (tiny mce and others)

closed as off-topic by Moose, Keyul Shah, David Manners, MTM, Dexter Aug 22 '14 at 11:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Moose, Keyul Shah, David Manners, MTM, Dexter
If this question can be reworded to fit the rules in the help center, please edit the question.

  • could you please tell me, which ones the hoster removed? My problem is, the wysiwyg is enabled by default, but at the product descriptions I still have to click the button to open the wysiwyg in a popup – user2357 Jun 11 '13 at 0:55
1

This is not a bug. It's a feature. This is how it is supposed to behave. 'Disabled by default' means that when a page is loaded where a WYSIWYG editor should appear the editor is not activated by default and there is a button to activate it. 'Enabled by default' means that the textareas with editors, load the editor when the page loads. If you don't want the editor you should set the field to 'Disabled completely'.
The texts in your textareas contain HTML elements because they were previously saved with the editor active. See if the so called issue reproduces when adding a new product with the editor disabled, without clicking on 'Show/Hide Editor'.

  • You don't understand..You just Vote Down any question you don't understand.. It worked before, I changed the settings from "Enabled by Default" to "Disabled by Default" and still the editor tiny-mce don't appear. And I haven't changed anything in the core files. Please reopen the question and post a good answer or give me another Vote Down if that's all you're good at :) – Pascut May 21 '13 at 18:35
  • I don't think it's important, but if for you is important, I didn't down vote you. I just recommended that this question should be closed. And I'm not the only one. There is a reason you need 5 close votes to close the question. If 5 people with enough reputation points say that this is not a real question, then this "is not a real question". I will not vote to reopen this. Try to ask an other question and do it right this time. Explain the expected result and the actual result. The more info you give, the easier is for others to give an answer. – Marius May 21 '13 at 18:49
  • 1
    What you say is true. But first I will make a debug by myself. I was a little bit lazy asking this question. Thanks anyway. – Pascut May 21 '13 at 18:52
  • the problem was that the hosting company removed some magento core files because "they contained viruses".. :) some js files were deleted (tiny mce and others) – Pascut May 22 '13 at 8:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.