I have a Magento Enterprise 1.13 installation that won't allow me to trigger reindexing the Catalog Category/Product Index and other indexes through the admin. The "Reindex Data" Action is not available even though it is set to Update on Save. It does seem to be automatically reindexing on save but does not on import

4 Answers 4


Bigger part of indexes are now meant to run in background. You have also option to schedule cron indexing. See http://www.magentocommerce.com/knowledge-base/entry/ee113-indexing for more details. There is no proof way to manually re-index via Admin


Ensure you are using a MySQL version that supports Triggers, first. As 1.13 EE uses them to automatically insert the data upon saving from the EAV tables to the flat tables.

Double check that the triggers exist in the database itself, especially if this was an upgrade.

Example of a trigger, first portion says on each update of table X do the following on tables X, Y, Z, etc. Mostly I've noticed these triggers are for UPDATE,DELETE,INSERT

AFTER UPDATE ON db.catalog_product_entity_int FOR EACH ROW

INSERT IGNORE INTO `cataloginventory_stock_status_cl` (`product_id`) VALUES (NEW.`entity_id`);
INSERT IGNORE INTO `catalogsearch_fulltext_cl` (`product_id`) VALUES (NEW.`entity_id`);
INSERT IGNORE INTO `catalog_category_product_index_cl` (`product_id`) VALUES (NEW.`entity_id`);
INSERT IGNORE INTO `catalog_product_index_price_cl` (`entity_id`) VALUES (NEW.`entity_id`);
INSERT IGNORE INTO `catalog_product_flat_cl` (`entity_id`) VALUES (NEW.`entity_id`);


My gripe as well is why was the option removed from the admin? Especially since its obviously possible doing indexing via php shell/indexer.php reindexall without issues. I have confirmed with Magento themselves that should still function the same.

As Petar mentioned, familiarize yourself with the list of items that Require a full reindex should also help:


I bet it might be caused by wrong permisson set to tmp folder. Check /var/locks/ folder permissions and see if there are any files. You should find there:


Check date of modification. If proper permission are set (755) just remove those files and try to re run indexing.


refer this link to reindex products in magento easily- http://www.codetweet.com/magento/reindexing-magento-programmaticaly/

  • 3
    Single link answers are not the best. explain a little what is found at the end of that url
    – Marius
    Commented Oct 15, 2013 at 10:27
  • the post on above link shows how to reindex products data in magento.You can find a well written php script and execute the script via command line to reindex
    – arp
    Commented Oct 17, 2013 at 7:58
  • that link is broken... well that site is at least... it says "Error establishing a database connection"; Commented Jun 22, 2016 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.