0

Firstly, I have little knowledge of the workings of Magento as I'm mainly a WordPress developer so please be gentle.

I have been tasked with moving an existing Magento install onto a VPS. The VPS is setup correctly and meets all the minimum requirements for Magento as noted via their magento_check.php document

When working offline (read: developer environment), The site is visible and seems to function as expected however after copying the files onto the new VPS, uploading the database to the host and ensuring that local.xml database credentials authenticate, I have been faced with an unexpected error.

The error simply reads:

Fatal error: Class 'Magento_Db_Adapter_Pdo_Mysql' not found in //app/code/core/Mage/Core/Model/Resource.php on line 165

I have tried reading articles from the Magento forums, namely: http://www.magentocommerce.com/boards/view./viewthread/667511/ and have attempted to perform the solutions listed here http://turnkeye.com/blog/disable-magento-compiler/ however this has proven ineffective as when attempting to perform this:

php -f compiler.php clear
php -f compiler.php disable

in the /shell directory, via SSH, as root, I am unable to progress and are faced with the same error:

Fatal error: Class 'Magento_Db_Adapter_Pdo_Mysql' not found in //app/code/core/Mage/Core/Model/Resource.php on line 165

Any advice on how to resolve this issue, or perhaps some links to potential fixes would be very much appreciated.

I'm can't provide any versioning info at this time, however, if you require it please tell me where I can find specific information.

0

I resolved this by following the migration guide for magento to the letter again.

http://www.magentocommerce.com/wiki/groups/227/moving_magento_to_another_server

0

For me the problem was that I had two Magento instances running on one server with APC as the cache backend. I made the mistake of both having the same prefix, which led to falsely cached classes and files.

Change the cache prefix and it should work again. An Apache server restart should be fine, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.