2

Our website is setup so you can browse by category or by brand. The layered navigation on the left works great when viewing by category (has the ability to filter by Colour / Size / Price / Brand). However, when viewing by brand the layered navigation includes every colour, size category available in the root category rather than being applicable to the list of products. It doesn't work to filter the products on the page. We'd like it to only display the available filters for the products on the page.

Hope that makes sense! I'm keen to get this resolved and happy to pay for someones time if they know a fix for it!

  • I'm not going to post this as an answer, as its too broad (and a lone-link) - but have a look at some old code we wrote here. – Ben Lessani - Sonassi May 17 '13 at 22:49
2

If you made some changes in the attributes configuration or products, you may need to re-index the data in your Magento in order to display the attributes in the layered navigation correctly. Also refresh the cache after that. Check this links, might be useful:

  • Thanks for your reply. I have re-indexed the data and cleared the cache but unfortunately it hasn't resolved issue. I think it's because I'm using a different product collection function to the standard category product list (does that make sense?!). – Sall Salter May 17 '13 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.