7

enter image description here

When I added an image above error display.

How to change permission to add image for all ?

  • 1
    Make sure you have 777 rights on the media folder recursively. – Marius Oct 9 '14 at 5:56
  • 1
    how to change media folder setting permision in magento. – coder Oct 9 '14 at 5:58
  • i am root access in my local in xamapp what am i do to solve issue? where to chanage permission. i am use another magento using his ip address in local in magento. that's i am confiuse. – coder Oct 9 '14 at 6:11
  • 1
    DO NOT EVER!!!! make a directory 777, anyone telling you that is a fool and has absolutely no clue about security. – user26528 May 24 '15 at 18:49
6

I needed to create /media/wysiwyg and set write permissions. It was not created because magento could not write into /media.

  • How did you set the write permissions on windows? – Black May 20 '18 at 15:29
  • @Black Right click on the folder > Properties > Security. – PiTheNumber May 22 '18 at 10:18
3

To set permissions on Windows:

  1. Right-click the file or folder, click Properties, and then click the Security tab.

  2. Click Advanced, and then click the Owner tab.

  3. Click Edit, and then do one of the following:

    • To change the owner to a user or group that is not listed, click Other users and groups and, in Enter the object name to select (examples), type the name of the user or group, and then click OK.

    • To change the owner to a user or group that is listed, in the Change owner to box, click the new owner.

  4. If you want to take ownership of the contents of the folder, select the Replace owner on sub containers and objects check box.

  5. Click OK, and then click Yes when you receive the following message:

      You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?
    
      All permissions will be replaced if you click Yes.
    

Note folder name is the name of the folder that you want to take ownership of.

  1. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.

Source: http://answers.microsoft.com/en-us/windows/forum/windows_vista-files/how-do-i-change-folder-and-file-permissions/465f2b42-63dd-4486-8dd1-c870290efeed

  • 1
    This is the right answer as the links in the comments above only provide infos about how to set in on Unix/Linux systems. – Anna Völkl Nov 11 '14 at 9:45
3

I checked that there is no wysiwyg folder in the media folder. I created it and wola it worked.

Hope this will work for those who are facing same problem.

  • This solution also worked for me. – camdixon Jun 13 '16 at 18:16
  • This worked, I wonder if the devs were drunk and forgot to add it... – Black May 20 '18 at 15:32
0

This is not a magento issue. It simply says that the media folder in the application root directory doesn't have writable permissions. To give write permissions to any folder you need to have root access to the webroot folder. To change the permissions on different folders you should go the Control Panel of your host account. There you will find an interface to change these permissions.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.