Hello Everyone I hope you are doing well. I have an issue I need help with Please.

I'm trying to add products to specific sub categories using Magento ver. I've been able to do it with no major problems until recently. I am not sure why. Now when I get to the point in which I am to select a category it does not give me the ability to expand the category tree (folder tree) to show sub categories to choose from. Could you please help me to solve this problem.

Here is a picture of what it looks like: Category tree with limited visibility of categories

In my particular situation the books category should be able to expand to show sub categories, but it is not doing so. That is my problem.

I'd like to have the sub categories of the books category show up in the category tree.

on a side note if I were to save the products to the books category then later on go back to change the category only the root and workshops folders are visible.

on another side note sometimes when I save and continue when adding a product it does not save properly and it redirects me to the dashboard.

Please help me

3 Answers 3


I also ran into this situation. The problem was in the negative value of the field "children_count" in the table "catalog_category_entity".


I figured out at least a temporary solution.

I basically created a new root category, moved all the sub categories to the new root category then moved the root category into where the original category was and deleted the old books category. I also had to readjust the subcategories so that they would get reindexed or something like that. I feel like I may have done more than necessary though.

I'm thinking it may have worked if you had taken the main subcategory and just moved it from one location to another (for example a root category) and back so that it could rerecognize it or something like that.

Not a very coding solution, but it seems to be working again.


I just ran into this problem right after upgrading from to

I tried a bunch of suggestions (e.g. run a query to change the level, create a new root dir and move the old stuff into it, blah, blah, blah) and they only made things worse.

Fortunately, I used PHPMyAdmin to backup the magento MySQL database before doing the upgrade. I deleted the live(!) catalog_category_entity table (and all its related tables' data!) then copied all their data back the from the backup tables. It was still messed up, but at least the website was displaying things correctly. Then I decided to reindex everything before taking a break this time it fixed it. (so, for me, the upgrade hosed it, restoring the backup tables and reindexing fixed it)

BTW, I also found that the js/scriptaculous directory got deleted during the upgrade (why?!?!? NOT cool Magento) and I put an old copy back to fix the picture zoom not working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.