1

I am using the SOAP API to interact with a Magento 1.7.0.2 installation. I use the SOAP V2 method salesOrder.addComment to change the status of an existing sales order.

I call the method with all params (sessionid, orderIncrementId, status, comment, notify). I set the param 'notify' to false. But this seems to have no effect. After the call the status of my sales order has changed, I can see the comment in the salesorder comment section and I also see the additional information "Customer Not Notified". But Magento sends an email anyway!

Why did that happen? Is this an expected behavior because I am changing the state of the sales order? How can I avoid this behavior that magento sends an email to the customer even if I set the notify flag to false?

2

You say:

"I call the method with all params (sessionid, orderIncrementId, status, comment, notify). I set the param 'notify' to false. But this seems to have no effect."

You should set the param 'notify' to '0', not to false.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.