0

Since a few days logging in to our Magento (1.8.1) backend is impossible - but only from one specific IP address, the IP address that used to be set at System -> Configuration -> Advanced -> Developer -> Developer Client Restrictions.

The issue at hand is that the login seems to be successful, yet I receive a blank admin page instead of the dashboard.

While trying to troubleshoot this issue I have of course changed this IP address to another IP address (1.2.3.4), cleared sessions and caches, even rebooted our server, but no luck.

Still receiving a blank page.

I activated all of the possible logging / developer options hoping this would give me a clue of what's wrong, maybe even on infamous fatal error, but no. Just a white screen and no suspicious or clueful entries in nginx, php or magento logs.

What makes it more strange is that this problem happens on multiple computers/browsers behind one specific (and fixed) IP address, yet if - for instance - I connect one of these computers to a 3G Hotspot (and as such connect using a dynamic IP address) I am able to successfully login to our backend. Now if I disconnect from the hotspot and on to the regular wifi (and as such continue using the fixed / problematic IP address) it works perfectly. I can navigate all pages of the backend -including the dashboard- without any issues.

Once logged off or timed out the issue re-appears.

Someone somewhere any clue on why this is happening and how to solve this?

  • is it only your admin page or is it white on your front end as well? – user14868 Oct 2 '14 at 9:41
  • Just with the admin page (multiple users). Frontend is fine. – Ottonet Oct 2 '14 at 10:09
1

In the end I found the problem. It was in the Amasty Errors Detector module (http://amasty.com/errors-detector.html). This module has functionality to log failed login attempts and put these IP addresses on a blacklist.

Even though we are using 1Password at this specific IP address apparently 4 failed logins where recorded and this IP address was put on the blacklist.

Completely forgot about the functionality of this extension and while looking for something else I saw this IP address on the blacklist.. Luckily the extension comes with a whitelist as well ;)

-1

I think the admin screen becomes blank, is with the cookies that are set by the magento. Follow the below procedure.

Go to app/code/core/Mage/Core/Model/Session/Abstract/Varien.php file within your magento directory. At line no.88 you will find the below code.

$cookieParams = array(
    'lifetime' => $cookie->getLifetime(),
    'path'     => $cookie->getPath(),
    'domain'   => $cookie->getConfigDomain(),
    'secure'   => $cookie->isSecure(),
    'httponly' => $cookie->getHttponly()
);

Replace the above code with below:

$cookieParams = array(
    'lifetime' => $cookie->getLifetime(),
    'path'     => $cookie->getPath()
//  'domain'   => $cookie->getConfigDomain(),
//  'secure'   => $cookie->isSecure(),
//  'httponly' => $cookie->getHttponly()
);

Clear the cache and browser cache too and reload the page.

  • Tried it, even in different browsers, but still can't login. Looking at the chrome inspector, the cookies are set just fine, both with an unpatched and the patched version of Varien.php – Ottonet Oct 3 '14 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.