0

I have a multi-store set up (Magento Community Edition) and want to translate one of the stores to French.

I've exported the product data and had it translated but before I tried importing I thought I'd check the product settings. It seems I need to change the scope of the relevant attributes (name, description, short description for example) to "Store View" before I import.

This works fine for description and short description but I can't change the name attribute and get the message:

The attribute code 'name' is reserved by system. Please try another attribute code

How do I change this so I can use the translated product names?

Any other quick tips on product data importing from folks who have done it before?

0

Have you tried changing the Scope within Catalog -> Attributes -> Manage Attributes I assume this is where you got that error message? However, I just changed it in one of my Magento stores with no error messages.

The only thing I'd suggest is to change them in the Database but that would be a bit risky if Magento won't let you change it.

  • Yeah, that's exactly where I got the error message. I've changed other attributes but this particular one seems to be problematic. Might consider a database change as a last resort but I suspect you are right in that there is probably a very good reason why Magento won't let me change it. – Darren Potter Sep 30 '14 at 10:27
  • I can change the scope there just fine, too. The error message sort of suggests you are trying to make a second attribute with the code name or alter the code name of this attribute... – user3154108 Sep 30 '14 at 10:36
  • Yeah, Magento appears to suggest that's what I'm doing though I'm quite simply selecting 'Store View' from the Scope dropdown and saving. Nothing else is changed. – Darren Potter Sep 30 '14 at 11:37
  • I tried researching further into this but ultimately arrived at the decision to try changing this in the database which proved to be successful. Thanks for the suggestion. – Darren Potter Oct 17 '14 at 9:46
0

You should be able to set the storeview you want to make edits for in the right upper corner, deactivate the checkbox use default and put your translated name for the french store view and the orignal name for the english store.

  • The problem is I don't get that option at all as the attribute is marked as global. This is why I'm trying to change the scope to "Store View" so I get that option. – Darren Potter Sep 30 '14 at 10:29
  • I see. The attribute is marked storeView by default on my stores, though. – user3154108 Sep 30 '14 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.