0

I am trying to move my magento site from local to live server, but I get this error.

Exception printing is disabled by default for security reasons.

Error log record number: 636829790955

I tried changing local.xml.sample to local.xml to see the problem also. I changed dbname, host, username and password inside app/etc/local.xml also. How to correctly upload the magento site? What are the steps to do so?

closed as too broad by David Manners, Keyul Shah, Mufaddal, Marius Jan 19 '15 at 11:32

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • hi.. for checking the issue rename local.xml from local.xml.sample at yourmagentodir/errors – Amit Bera Sep 30 '14 at 4:53
  • Try following through the steps at magento.stackexchange.com/a/429/158 to find the complete error. – David Manners Jan 19 '15 at 9:32
  • 1
    go to /var/report/636829790955 and tell us what is the real error. – Julien Lachal Jan 19 '15 at 9:54
1

Before doing anything else, it would be wise to empty all of the cached content.

Log into the manager, then: Site --> Clear Cache Clear your sessions: Security --> Flush All Sessions

  • Actually, before clearing cache, make sure file/directory permissions are set properly so Magento can write to the var/ directory. Most problems arise because Magento can't write sessions files, report files and sometimes will partially recover and write cache files to the system /tmp folder. This is the root cause of the amazingly non-clearable cache everyone runs into where you change the base urls in the database, can see they've changed but no amount of clearing cache allows them to be read. – Fiasco Labs Sep 30 '14 at 22:09
0
  1. Check in var/report/ for a file named with that number. Read its contents for stack trace that outlines the issue causing Magento to die
  2. If no files are present in var/report/ then file/directory permissions haven't been properly set. Set file/directory permissions recursively for var/ so that the web server can write temporary files

Generally, file permissions are set as follows:

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
chmod o+w var app/etc
chmod 550 mage
chmod -R o+w media

Steps needed to move Magento to a different web server.

0

Please Follow below Steps.

1. Open your core_config_data table in phpMyAdmin.

2. Find the following rows for your unsecure section, they should look like the following:

PATH                         VALUE
web/unsecure/base_url        http://www.mydomain.com/
web/unsecure/base_link_url   {{unsecure_base_url}}
web/unsecure/base_skin_url   {{unsecure_base_url}}skin/
web/unsecure/base_media_url  {{unsecure_base_url}}media/
web/unsecure/base_js_url     {{unsecure_base_url}}js/

3. Replace http://www.mydomain.com/ with your appropriate domain url (trailing slash necessary) and if you’ve installed in a subfolder append it with a / after it.

4. Find the following rows for your secure section, they should look like the following:

PATH                         VALUE
web/secure/base_url          https://www.mydomain.com/</td></tr>
web/secure/base_link_url     {{secure_base_url}}</td></tr>
web/secure/base_skin_url     {{secure_base_url}}skin/</td></tr>
web/secure/base_media_url    {{secure_base_url}}media/</td></tr>
web/secure/base_js_url       {{secure_base_url}}js/</td></tr>

5. Replace https://www.mydomain.com/ with your appropriate domain url (trailing slash necessary) and if you've installed in a subfolder append it with a / after it. If you haven't received your security certificate and enabled TLS/SSL yet, use http instead of https

6. Clear /var/cache, /var/session after changing base_urls and when you have access to your system reindex your URL_rewrite index. Clearing cache and sessions is necessary because your config is cached and clearing it forces a reread of the configuration data from the core_config_data table and reestablishment of sessions with the proper information.

NOTE: IF YOU HAVE SET YOUR BASE_URL correctly for web/unsecure/base_url and web/secure/base_url YOU DO NOT HAVE TO MESS AROUND WITH CHANGING THE {{UNSECURE_BASE_URL}} and {{SECURE_BASE_URL}} MACROS in the rest of the entries.

This is going to definitely work.

  • I did it but I get this error.Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) – Sid Sep 30 '14 at 5:25
  • 1
    Heh, 32M memory limit. On shared hosting. Usual memory_limit issue, increase it to 256M, if it won't increase, find a capable Magento host. – Fiasco Labs Sep 30 '14 at 20:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.