0

After some issues with Upgrade to latest stable versions of components I decided to rollback, so I went to System > Tools > Backups and clicked on Rollback of latest System Backup I did before the upgrade. I also did a Database and Media Backup.

Now I get the following error and it seems that a large number of files have disappeared on the server side:

Warning: include_once(Mage/Core/functions.php): failed to open stream: No such file or directory in /var/www/web108/html/www/app/Mage.php on line 50 Warning: include_once(): Failed opening 'Mage/Core/functions.php' for inclusion (include_path='/var/www/web108/html/www/app/code/local:/var/www/web108/html/www/app/code/community:/var/www/web108/html/www/app/code/core:/var/www/web108/html/www/lib:.:/usr/share/php:/usr/share/php/PEAR:/var/www/web108/html') in /var/www/web108/html/www/app/Mage.php on line 50 Warning: include_once(Varien/Autoload.php): failed to open stream: No such file or directory in /var/www/web108/html/www/app/Mage.php on line 51 Warning: include_once(): Failed opening 'Varien/Autoload.php' for inclusion (include_path='/var/www/web108/html/www/app/code/local:/var/www/web108/html/www/app/code/community:/var/www/web108/html/www/app/code/core:/var/www/web108/html/www/lib:.:/usr/share/php:/usr/share/php/PEAR:/var/www/web108/html') in /var/www/web108/html/www/app/Mage.php on line 51 Fatal error: Class 'Varien_Autoload' not found in /var/www/web108/html/www/app/Mage.php on line 54

This is a terrible situation, completely lost here for next steps, any suggestions?

0

I think you might have compilation mode enabled. Try disabling it and reloading, the error should go away after that.

  • Thanks for your response. I cannot access Admin Panel anymore, how do I do this? – philippecoley Sep 29 '14 at 16:36
  • Thanks folder includes is no longer there. looked at the backup I have and the config.php file shows those two lines commented out. – philippecoley Sep 29 '14 at 17:11
  • Try "php shell/compiler.php disable" anyway from your root Magento folder via SSH. – mbalparda Sep 29 '14 at 17:12
  • I was not able to access server by SSH, requested a server restore instead. This has now been done but I continue to have problems, I created a new request here: magento.stackexchange.com/questions/37556/… – philippecoley Sep 30 '14 at 11:57
0

i used this command and did it. php -f compiler.php clear php -f compiler.php disable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.