0

I have several performances issues on my search on magento 2.4.7, it take at least 5 second to load result. After investigate i can see it's due to the cache.

I m not sure it save. For example on this key : REQUEST_DECLARATION

When i call the save method and do that $this->load($id) on this file Cm/Cache/Backend/Redis.php , it return all the time false . But the save doesn t generate an error...

My env.php configuration is like this :

    'session' => [
    'save' => 'redis',
    'redis' => [
        'host' => 'XXXXXXXXXXXXXX.cache.amazonaws.com',
        'port' => '6379',
        'password' => '',
        'timeout' => '2.5',
        'persistent_identifier' => '',
        'database' => '11',
        'compression_threshold' => '2048',
        'compression_library' => 'gzip',
        'log_level' => '1',
        'max_concurrency' => '6',
        'break_after_frontend' => '5',
        'break_after_adminhtml' => '30',
        'first_lifetime' => '600',
        'bot_first_lifetime' => '60',
        'bot_lifetime' => '7200',
        'disable_locking' => '0',
        'min_lifetime' => '60',
        'max_lifetime' => '2592000',
        'sentinel_master' => '',
        'sentinel_servers' => '',
        'sentinel_connect_retries' => '5',
        'sentinel_verify_master' => '0'
    ]
],
'cache' => [
    'frontend' => [
        'default' => [
            'id_prefix' => 'thom_',
            'backend' => 'Magento\\Framework\\Cache\\Backend\\Redis',
            'backend_options' => [
                'server' => 'XXXXXXXXXX.cache.amazonaws.com',
                'database' => '10',
                'port' => '6379',
                'password' => '',
                'compress_data' => '1',
                'compress_tags' => '1',
                'compress_threshold' => '20480',
                'compression_lib' => 'gzip',
                'preload_keys' => [
                    'JMG_EAV_ENTITY_TYPES',
                    'JMG_GLOBAL_PLUGIN_LIST',
                    'JMG_DB_IS_UP_TO_DATE',
                    'JMG_SYSTEM_DEFAULT'
                ]
            ]
        ],
        'page_cache' => [
            'id_prefix' => 'thom_'
        ]
    ],

Could you help me ? Did i miss something? Thanks a lot

1
  • If i disable use_lua on env.php , it s really faster !! Why it s not in the documentation ! 'backend_options' => [... "use_lua"=> false..] Commented Jul 3 at 13:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.