0

I'm trying to display the newest Products on a CMS page, but it doesn't work. I've tried several codes ({{block...), but none of them would work. I have read about issues with the RWD-Theme but couldn't find a fix to it.

No server error, only blank space.

Right now I'm using this code:

{{block type="catalog/product_new" name="home.catalog.product.new" column_count="3" products_count="8" alias="product_homepage" template="catalog/product/new.phtml"}}

1

Double-check that you have declared any products as 'new' with the Set Product as New from Date attribute. You 'll have to declare both a start and end date.

Also, make sure you have re-indexed your site after you have declared products as new.

There are some 3rd party templates out there that pick up new products based on the date they were added to the system, but most do not. You have to force the 'new' status. I believe this is also true of rwd theme.

FWIW, here's what I use:

{{block type="catalog/product_new" template="catalog/product/new.phtml" products_count="15" breakpoints="[0, 1], [320, 2], [480, 3], [768, 4], [960, 5], [1280, 6]" move="1" pagination="1" centered="0" hide_button="1" block_name="New at SunshieldGlasses.com"}}

The breakpoint stuff in there you can ignore. I use it for forcing different numbers of products to display based on the customer's viewport width. Other values declared there are variables being passed into my new.phtml file which handles a lot of stuff related to formatting the output and, obviously, collecting the products to be displayed.

  • Thanks a lot Dave. It seems like I totally ignored that "Set Product as New" Attribute. Now it works. – bibz Sep 29 '14 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.