3

I am facing issue with my pagebuilder on server. I am using apache server for my Magento (2.4.7) instance. When I first open the category edit page on incognito mode, I open the pagebuilder, add my content and save the category. It works the first time. If I again open the pagebuilder, update the content and try to save category, it gets stuck with a console error message:

Page Builder was rendering for 5 seconds without releasing locks

This issue is also same on other pages where a pagebuilder is added. If I close my incognito tab and open a new one, the same process is repeated, it works the first time and then, it just shows a loader.

  • I have tried the solutions like, addind missing <item> tags in pagebuilder element in xml file.
  • I have also made sure there is no other pagebuilder on category edit page which could conflict with each other.

Note: The issue is not there on my local instance with the same codebase. It only appears on live server.

4 Answers 4

1

We are also facing same problem and adobe team have shared patch with us and after apply that patch issue is resolved.

If anyone having facing same problem then you can use attached patch file. I hope it works. Thanks.

Patch Link:- https://drive.google.com/file/d/1NCOaxO7sKc7wkIEWtrWCx-uJlnAvzw2P/view

1

This weird issue is present in many Magento versions and there are many fixes available over the internet.

It is related to chrome, not particularly a Magento 2-related issue.

Here are some issues, I hope you will find a related commit that will fix your issue.

Please go through these reference links :

https://experienceleague.adobe.com/en/docs/commerce-knowledge-base/kb/support-tools/patches/v1-1-28/acsd-48857-unable-to-save-changes-after-editing-with-pagebuilder

https://github.com/magento/magento2/issues/37516

https://github.com/magento/magento2-page-builder/commit/69953bcb7f1ac3a793ec7e0b09fc07e680a80856

https://github.com/magento/magento2/issues/34898

https://github.com/magento/magento2/issues/29977

https://github.com/magento/magento2/issues/28706

2
  • 1
    Hello Jigar, Thank you, but I am using 2.4.7 which has the patch applied. I do not have multiple builder on page. Also, I am facing the same issue on FireFox as well. Commented May 21 at 13:39
  • 1
    Yes, Magento already fixed this in 2.4.7 but somehow many users still facing this issue as whenever it exceeds 5 seconds it throws this same error :( Commented May 21 at 20:32
1

I have the same problem with Magento 2.4.7 and different browsers. In previous versions, I never experienced this and did not need to apply any fix. In my case, the problem started as soon as I updated to Magento 2.4.7

0

Chrome just released an update and after installing it, I can save the Page Builder content normally. I have not tested with other browsers.

4
  • Hello Lopez, Would you please let me know which chrome version are you using? Is it 120? Commented May 23 at 12:35
  • I checked with Chrome's latest version 125, but the issue is still there. Commented May 23 at 13:20
  • Chrome Version 125.0.6422.76 I am not sure it has anything to do with it bit I also Updated from Windows 10 to Windows 11
    – N Lopez
    Commented May 24 at 4:46
  • 1
    After using it a little bit more I found out it does not work 100% of the time but at least it works around 90% of the time. After changing anything I copy my work in case it does not work and I try again.
    – N Lopez
    Commented May 24 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.