4

have changed the Base Link Url(base link url) ( not the base url) . Now my site is not accessible except for the home page. How to solve this ? . This option is not visible in core_config_data table too.

I am using magento 1.9

I changed it

system -> web -> unsecured -> base link url .

Now I am not able to access anything in my site. as am getting two index.php in the url.

4

You need to have access to your database (command line or phpmyadmin)

Select * from core_config_data where value like 'http%';

You will be able to find your urls. Make note of your config_id's

You can now up date the URLs you need

Update core_config_data set value = 'http://www.domain.com/' where config_id in (list your id's here);

ALWAYS BACK UP FIRST

2

You need to check base link of site.

select * from core_config_data where path  like '%base_link_url%'

If it not proper then you need to change base link.

update  core_config_data set value ='http://yousiteurl' where path  like '%base_link_url%'

As for index.php check Apache mod_rewrite enable and check magento seo engine is enable or not.if it not enable then you need to enables

 update  core_config_data set value =1 where path  like '%use_rewrite%'
1

Its very simple,

goto your phpmyadmin,

select your database,

find table core_config_data,

then select this table,

and find web_unsecure_url and web_secure_url . for both paste your site url with / at last.

0

ummm - all good advice IF the O.P. had not said that he needs to edit base LINK url - which is NOT in core_config_data...

I have the same issue - even though i can manually edit the path to remove the second 'index.php/' entry - which gets me to the admin panel page to edit the base link url entry (removing the index.php from the entry - i can't save the configuration, since it fails and redirects to 404 (because it tries to save to a path including ... index.php/inex.php/... - so i guess that the O.P. has (had)the same problem ... i need to edit the base LINK url outside of magento

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.