0

Is there a way to disable page builder for product description field? I know there are articles how to remove from category description, but I didn't find for the product description, I tried to do it myself (result below) but it doesn't work. Any ideas?

<?xml version="1.0" encoding="UTF-8"?>
<form xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Ui:etc/ui_configuration.xsd">
    <fieldset name="content" sortOrder="10">
        <container name="container_description" sortOrder="10">
            <field name="description" template="ui/form/field" sortOrder="50" formElement="wysiwyg">
                <argument name="data" xsi:type="array">
                    <item name="config" xsi:type="array">
                        <item name="source" xsi:type="string">product</item>
                        <item name="wysiwygConfigData" xsi:type="array">
                            <item name="is_pagebuilder_enabled" xsi:type="boolean">false</item>
                        </item>
                    </item>
                </argument>
            </field>
        </container>
    </fieldset>
</form>

2 Answers 2

1

Try the following way:

Open the attribute from Magento admin, then select Catalog Input Type for Store Owner dropdown enter image description here

Save it.

Alternative solution:

If you want to programmatically modify this behavior, then create a plugin for vendor/magento/module-page-builder/Ui/DataProvider/Product/Form/Modifier/Eav/WysiwygConfigDataProcessor.php, and return the following code from your plugin.

$wysiwygConfigData['is_pagebuilder_enabled'] = false;

Will disable the page builder

1

Please go to admin panel

Store => Attributes => Product

enter image description here

Click on description after open new page see below enter image description here

change page builder to text editor

after apply below commands.

php bin/magento c:f
php bin/magento indexer:reindex

after show final image product admin

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.