0

When logging into my admin panel it's throwing the error below, causing me to be unable to access the admin panel.

1 exception(s):

Exception #0 (InvalidArgumentException): Item with identifier Magefan_Community::elements does not exist

Exception #0 (InvalidArgumentException): Item with identifier Magefan_Community::elements does not exist

#1 Magefan\Community\Plugin\Magento\Backend\Model\Menu\BuilderPlugin->afterGetResult() called at [vendor/magento/framework/Interception/Interceptor.php:146]
#2 Magento\Backend\Model\Menu\Builder\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/framework/Interception/Interceptor.php:153]
#3 Magento\Backend\Model\Menu\Builder\Interceptor->___callPlugins() called at [generated/code/Magento/Backend/Model/Menu/Builder/Interceptor.php:23]
#4 Magento\Backend\Model\Menu\Builder\Interceptor->getResult() called at [vendor/magento/module-backend/Model/Menu/Config.php:153]
#5 Magento\Backend\Model\Menu\Config->_initMenu() called at [vendor/magento/module-backend/Model/Menu/Config.php:116]
#6 Magento\Backend\Model\Menu\Config->getMenu() called at [vendor/magento/module-backend/Model/Url.php:365]
#7 Magento\Backend\Model\Url->_getMenu() called at [vendor/magento/module-backend/Model/Url.php:325]
#8 Magento\Backend\Model\Url->getStartupPageUrl() called at [vendor/magento/module-backend/App/AbstractAction.php:187]
#9 Magento\Backend\App\AbstractAction->_processUrlKeys() called at [vendor/magento/module-backend/App/Request/BackendValidator.php:175]
#10 Magento\Backend\App\Request\BackendValidator->validate() called at [vendor/magento/framework/App/Request/CompositeValidator.php:40]
#11 Magento\Framework\App\Request\CompositeValidator->validate() called at [vendor/magento/framework/App/FrontController.php:192]
#12 Magento\Framework\App\FrontController->processRequest() called at [vendor/magento/framework/App/FrontController.php:147]
#13 Magento\Framework\App\FrontController->dispatch() called at [vendor/magento/framework/Interception/Interceptor.php:58]
#14 Magento\Framework\App\FrontController\Interceptor->___callParent() called at [vendor/magento/framework/Interception/Interceptor.php:138]
#15 Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/framework/Interception/Interceptor.php:153]
#16 Magento\Framework\App\FrontController\Interceptor->___callPlugins() called at [generated/code/Magento/Framework/App/FrontController/Interceptor.php:23]
#17 Magento\Framework\App\FrontController\Interceptor->dispatch() called at [vendor/magento/framework/App/Http.php:116]
#18 Magento\Framework\App\Http->launch() called at [vendor/magento/framework/App/Bootstrap.php:264]
#19 Magento\Framework\App\Bootstrap->run() called at [pub/index.php:29]

I haven't changed anything, but other accounts user access, and it began throwing this error. Any assistance would be much appreciated.

1 Answer 1

0

Open the acl.xml file located in the Magefan_Community module directory (app/code/Magefan/Community/etc/acl.xml). Verify that the ACL rule for the "Magefan_Community::elements" resource is correctly defined. It should resemble something like this:

 <resource id="Magefan_Community::elements" title="Magefan Community" translate="title" sortOrder="10">

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.