0

I installed Magento 2.4.6-p3 by 1-click installation under Hostmonster webhosting c-panel. I didn't touch any thing. It went through well and gave me Admin Access of Magento 2.4.6-p3.

I searched whole last week to fix 'product not showing issue', and read about reindex via SSH. So, I ran it found the following error while reindex. I ran it under my webhosting Hostmonster SSH.

enter image description here

catalog search index process error during indexation process: could not ping search engine: No alive nodes found in your cluster

Could you help me how to fix this issue under my webhosting at Hostmonster environment? Should I put some kinds of SSH command to fix? Or, change some value under Magento Back End Admin?

'No alive nodes found in your cluster' kept showing while I click 'Test Connection' under Admin - Configuration - Catalog. Could you help me how to fix this issue and use Magento 2.4.6-p3 properly under Hostmonster webhosting environment?

enter image description here

How can I check if the opensearch is working? As I see Store - Configuration - Catalog, the opensearch was set as default. As I test connection, No alive nodes found in your cluster just as I posted the error image. After 1-click installation under c-panel on Hostmonster, I haven't touch any thing. Every thing should be set as default mode.

Is there any way to start the opensearch if it was turn off as a default mode? How can I turn it on?

Many many thanks. Best, CMYK337

1
  • Please restart your Elasticsearch service and ensure that you are using the correct host.
    – Msquare
    Jan 24 at 7:16

1 Answer 1

0

1st Start -------> elasticsearch

2nd Start--------> Xampp or wamp

Then Go to Magento root Directory ---> Run CMD Command

Paste and Enter Following Command

php bin/magento indexer:reindex

--------After Finish------

Then Paste and Enter Following Command

php bin/magento cache:flush

its woking..

Please try this. let me know this is working or not. if my solution is working then accept my answer and give an upvote.

thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.