0

Is Magento 2.4.5-p5 compatible with MariaDB 10.6.16? I am runing Magento 2.4.5-p5 on a Centos 7 Server running MariaDB 10.4. We are preparing for a move to AlmaLinux OS 8.
I am trying to upgrade some Amasty Extensions on the Centos 7 server and the Extensions require MariaDB 10.6.16. I am told by my Server Tech Support, if I ungrade to MariaDB 10.6.16 I cannot go back to MariaDB 10.4. Thanks for your help...

Thank you, Richard Wendrock

1 Answer 1

0

The Magento Core team (Adobe) officially tested and supported MariaDB 10.2-10.4 for Magento 2.4.5. However, the community has experienced like you in the past, and they have applied the customization or a patch to make Magento allow MariaDB 10.6. I also used MariaDB 10.6 for Magento 2.4.5 on a few projects, and it works as expected.

You can override the MariaDB-(10.2-10.4) value of the supportedVersionPatterns argument within the Magento\Framework\DB\Adapter\SqlVersionProvider type declaration in your custom module.

File path: app/code/YourVendor/YourModule/etc/di.xml.
Content:

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:ObjectManager/etc/config.xsd">
    <type name="Magento\Framework\DB\Adapter\SqlVersionProvider">
        <arguments>
            <argument name="supportedVersionPatterns" xsi:type="array">
                <item name="MariaDB-(10.2-10.4)" xsi:type="string">^10\.[2-6]\.</item>
            </argument>
        </arguments>
    </type>
</config>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.