1

While Installing the composer throws the following error

The PHP exe file you specified did not run correctly: C:\xampp\php\php.exe The php.ini used by your command-line PHP is: C:\xampp\php\php.ini

A setting in your php.ini could be causing the problem: Either the 'extension_dir' value is incorrect or a dll does not exist.

Program Output: PHP Warning: PHP Startup: Unable to load dynamic library 'php_Sockets.d11' (tried: C:\xampp\php\ext\php_Sockets.d11 (The specified module could not be found), C:\xampp\php\ext\php_php_Sockets.d11.dll (The specified module could not be found))

I have tried following

The path for extensions in php.ini has been changed to Absolute path Cross verified whether the extension present in the specified path

But still facing the same issue, do anyone have any idea about it?

Am using xampp server & Windows OS

1 Answer 1

1

Please go into your xampp and open Apache -> Config then click on php.ini file. Once file is open then search for socket extension, if you find that extension then remove the semicolon(;) from it.

If this is not available in your xampp's php.ini then directly add extension=sockets in php.ini where other extensions were added.

After saving the file Restart your Apache and Check issue is resolved or not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.