0

I did a new installation of Magento (2.4.6-p2) and did the data migration from Magento 1. Everything seems to work, except the catalog pages, which give the following error on the frontend:

Error: Cannot instantiate interface Magento\AdvancedSearch\Model\Client\ClientOptionsInterface in /var/www/html/magento2/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php:121

I have OpenSearch 2.11. In Magento backend the test is ok. But I can't reindex the Catalog Search.

If I type:

bin/magento indexer:reindex catalogsearch_fulltext

the result is:

Catalog Search index process error during indexation process: Cannot instantiate interface Magento\AdvancedSearch\Model\Client\ClientOptionsInterface [Exit 1]

Please help me to resolve this issue.

1 Answer 1

0

is it possible that the indexer has hung? You may have already tried this but try:

1- php bin/magento indexer:status

2- php bin/magento indexer:reset [TypeIndex]

when index is reset:

3- php bin/magento indexer:reindex [TypeIndex]

4- php bin/magento cache:flush

As a last option, restart opensearch (?).

Tell me if it doesn't work for you and I'll think of something else.

4
  • I had already tried with these commands. But the problem was always the same. After various vicissitudes, I have now solved the problem by simply enabling the "Magento_Elasticsearch" module.
    – PinoL
    Dec 1, 2023 at 9:26
  • Oh, and haven't you needed to disable opensearch safe mode??? Dec 2, 2023 at 10:50
  • No. Enabling the "Magento_Elasticsearch" module, Opensearch now is ok. I didn't do anything else.
    – PinoL
    Dec 4, 2023 at 10:07
  • I have a problem with opensearch today and the solution, after hours trying fix it was restart the server :D Dec 5, 2023 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.