0

I'm trying to change English default language to Italian, into the store view.

I installed the language package, which is now used in the backoffice, but I cannot manage to change it on the front office.

Anyone know the solution?

enter image description here

2
  • Hello Elisa, have you changed the store using Store View dropdown in admin top left corner? Commented Nov 22, 2023 at 13:16
  • No, it's probably a problem with the config.php file as it says Cladiuss. I haven't installed Magento and I don't know what basic settings were given, locally I didn't have these problems. Commented Nov 23, 2023 at 10:20

1 Answer 1

0

It seems that this configuration value has been included either in your app/etc/config.php file (most probably), or in your app/etc/env.php file.

This way of setting the configuration prevents you from modifying it in the back office. Note that this might be done on purpose for some configuration to prevent admin users to mess with some of the config.

In your case, I see 2 possible solutions :

Solution 1

If this is a mistake, you can remove the value from the app/etc/config.php file (or env.php), clear the cache, and go back to your back office to define it from there.

Solution 2

If this value has been set in the app/etc/config.php file (or env.php) for every store view, you can add an entry in the array for your new Italian store view.

1
  • Yes, probably the problem lies here, now I have overcome it with a command directly in the console php bin/magento info:language:list + php bin/magento setup:store-config:set --language=it_IT Commented Nov 23, 2023 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.