0

We are using the Magento 2.3.5 version we want to update the version from 3.79.1 to 3.97.0 in requirejs-config.js

file-path - vendor/gene/module-braintree/view/base/requirejs-config.js

when we are override in our theme with an updated version - app/design/frontend/Infortis/base/Magento_Paypal/requirejs-config.js

Then in the browser view page source it is showing 2 times instead of 1.SO it is not override it just add new there.

How to override requirejs-config.js ?

2

1 Answer 1

0

You need to put your overriding requirejs-config.js file in

app/design/frontend/<your-vendor>/<your-theme>/Magento_BrainTree/

Also, note that this will override only for frontend. As the file to be overriden is a base file, if you want it overridden in adminhtml as well you have to copy the file in your adminhtml theme as well.

app/design/adminhtml/<your-vendor>/<your-theme>/Magento_BrainTree/
3
  • When we checked in frontend via the view-page-source then 2 times are coming Nov 2, 2023 at 7:16
  • For any change to reflect for requirejs-config.js we need to run both setup:upgrade and static content deploy commands. Have you run both of them? Nov 2, 2023 at 9:40
  • yes i run both commands still it is showing 2 times Nov 2, 2023 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.