0

I am working on Magento 2.4.1.

I have configured a docker environment for multiple Magento projects for MySQL, Redis, Elasticsearch, and RabbitMQ.

by default, I have not defined a version in the docker-compose file, so it has installed mysql8 latest.

So, when I run the command setup:upgrad it shows me the error:

Current version of RDBMS is not supported. Used Version: 8.1.0. Supported versions: MySQL-8, MySQL-5.7, MariaDB-(10.2-10.4)

3 Answers 3

1

I have changed the version in app/etc/di.xml

    <type name="Magento\Framework\DB\Adapter\SqlVersionProvider">
        <arguments>
            <argument name="supportedVersionPatterns" xsi:type="array">
                <item name="MySQL-8" xsi:type="string">^8\.1\.</item>
                <item name="MySQL-5.7" xsi:type="string">^5\.7\.</item>
                <item name="MariaDB-(10.2-10.4)" xsi:type="string">^10\.[2-4]\.</item>
            </argument>
        </arguments>
    </type>

It worked for me, and it solved my problem.

Thank you.

1

First, check your Mysql version and update this depending on your version if your version is MariaDB 10.6 your configuration will be for this file app/etc/di.xml

<type name="Magento\Framework\DB\Adapter\SqlVersionProvider">
    <arguments>
        <argument name="supportedVersionPatterns" xsi:type="array">
            <item name="MySQL-8" xsi:type="string">^8\.0\.</item>
            <item name="MySQL-5.7" xsi:type="string">^5\.7\.</item>
            <item name="MariaDB-(10.2-10.6)" xsi:type="string">^10\.[2-6]\.</item>
        </argument>
    </arguments>
</type>
2
0

H have the same problem, I have the same problem, I am trying to upgrade from Magento 2.4.1-p1 - Magento 2.4.2 incrementally staged up to the latest 2.4.6.

However, my new server has only Mariadb 10.5 installed and I've hit this error. I presume this is overriding the checks Magento / composer checks for and accepts? Are there any potential implications known for this workaround? looking at the recommended spec for Magento it doesn't use Maridb 10.5 but jumps from Mariadb 10.4 to 10.6. I wonder Why? thanks in advance

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.