4

While upgrading Magento Enterprise version from 2.4.5-p4 to 2.4.5-p5, i get the following error on running composer require-commerce magento/product-enterprise-edition=2.4.5-p5 --no-update --force-root-updates

Could not find a magento/project package matching "magento/magento-cloud-metapackage 2.4.5"

FYI : I already ran the command composer require magento/composer-root-update-plugin:'*' before upgrade.

Any help to fix the issue would be helpful. Thanks in advance.

1
  • Any luck? on the same we are also facing same!! Commented Dec 11, 2023 at 15:53

1 Answer 1

1

Because you are accessing private package (Magento EE)

composer config --global http-basic.repo.magento.com <public_key> <private_key>

Image how key look like: https://i.sstatic.net/mYhJE.png

use this before installing the Magento app

Thanks

2
  • Hi, unfortunately, doesnt work. same error.
    – M2 Noob
    Commented Oct 6, 2023 at 13:49
  • 1
    I just had this problem and it was because someone had stored invalid credentials in auth.json, so even though the credentials stored in composer global config were good and correct, they were being overridden by that auth.json file Commented Apr 12 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.