0

I have problem with so old version Magento (customer didn't moved for a whole time). I can login in admin panel, but nothing can press. No one button, any action, nothing.

I tried this one: increased

memory_limit = 128M

and clear cache

 sync; echo 3 > /proc/sys/vm/drop_caches

But nothing happens(

1 Answer 1

0

To debug this,

Initial Steps to identify the issue

  • check the browser console to get any errors reported

  • check the system.log and exception.log in var/log directories

  • check the PHP and Webserver (Apache / Ngingx) logs

If its a production store, enable the maintenance mode (add the maintenance.flag) and enable the developer mode in index.php file

Mage::setIsDeveloperMode(true); // Enables Developer Mode

You can also keep the store in production mode and enable the developer mode only for your IP in index.php

$allowed = array('xx.xxx.xx.xxx);
if (in_array($ip, $allowed)) { 
    Mage::setIsDeveloperMode(true); // Enables Developer Mode
    ini_set('display_errors', 1); // lets also set this, though turning on developer mode is sufficient
    error_reporting(E_ALL & ~E_WARNING & ~E_NOTICE); 
}

These steps are very much sufficient to get the actual error behind the issue that you face.

As a sidenote, Have been working with Magento since 1.3.x. days and these steps are so basic and fundamental to solve the page loading issues due to non-explicit fatal errors / exceptions, that every backend magento developer should know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.