0

I'm and very new to Magento so please forgive me. Basically I was working on our development server trying to change the layout of our main page. I changed configuration->catalog->catalog->listmode from grid/list to just grid, and now I've encountered a problem.

When every I try to load the admin panel, I am stuck in an infinite loading loop, and when I try to open up the configuration settings, I get sent back to the login screen and I get a "visible section not found" exception. What's weird to me is that the customer facing side is unaffected and fully functional.

Like I said I am very new to Magento and don't really know what I'm doing and don't really know where to begin troubleshooting.

Things I've tried,

php bin/magento setup:static-content:deploy

php bin/magento cache:disable (and then re-enabled)

php bin/magento deploy:mode:set developer

rm -rf pub/static/frontend var/cache var/page-cache generated/

These seemed like the only suggestions I could find online, but I don't really know where to go from here. I think I need a way to revert my changes, but I don't know how I would do that outside of the admin panel. Any suggestions would be greatly appreciated.

Thank you in advance

2 Answers 2

0

Please run below commands and check:-

rm -rf pub/static/frontend/* var/cache/* var/page-cache/* generated/*
php bin/magento cache:enabled
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
chmod  -R 777 var/ pub/ generated/
8
  • Didn't work. Still having the same issue. Thanks though for trying
    – Isaac
    Commented Aug 1, 2023 at 13:03
  • Inspect the page and go to Network tab check the and check the status of the files.
    – MP Raj
    Commented Aug 1, 2023 at 13:15
  • Everything looks normal except one has a status code of 302. I appears to be something involving the log in credentials.
    – Isaac
    Commented Aug 1, 2023 at 13:28
  • I also just noticed that on the log in screen there is another file with the 302 code. stage.---.com/cdn-cgi/challenge-platform/scripts/invisible.js
    – Isaac
    Commented Aug 1, 2023 at 13:57
  • You can check the server logs
    – MP Raj
    Commented Aug 1, 2023 at 13:58
0

Please run below Magento command

rm -rf generated/ var/view_preprocessed/ && php -d memory_limit=-1 bin/magento s:up && php -d memory_limit=-1 bin/magento s:s:d -f && php bin/magento c:f && chmod 777 -R var/ generated/ pub/static/

1
  • That did the same thing as the solution before. Thank you though
    – Isaac
    Commented Aug 2, 2023 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.