3

I've just installed Magento version 1.9.0.1, and now testing "checkout". I got the following error message. Please, someone help.

Step 1: Log as Customer -

http://www.studentfilmmakers.com/filmgear

Step 2: Select this product (or any product), and Click "Add to Cart"

http://www.studentfilmmakers.com/filmgear/index.php/magazines-c248/studentfilmmakers-magazine-digital-edition-march-2007-edition.html

Step 3: Fatal error message -

Fatal error: Class 'SoapClient' not found in /home/education/public_html/filmgear/app/code/core/Mage/Usa/Model/Shipping/Carrier/Fedex.php on line 134
  • is php soap enabled? – echoashu Sep 23 '14 at 15:52
  • can you please update the code of Shipping/Carrier/Fedex.php on line 134 this – Keyul Shah Sep 23 '14 at 15:57
5

Diagnose

Look up the following inside your script file

phpinfo();

If you can't find Soap Client set to enabled like so: the way soap should appear in phpinfo()

Fix

Do the following:

  1. Locate php.ini in your apache bin folder, I.e Apache/bin/php.ini
  2. Remove the ; from the beginning of extension=php_soap.dll
  3. Restart your Apache server
  4. Look up your phpinfo(); again and check if you see a similar picture to the one above
  5. If you do, problem solved!

On the other hand if this doesn't solve your issue, you may want to check the requirements for SOAP here. Also in the comment section you can find good advice on connecting to https.

5

Facing same issue on ubuntu OS + PHP7 I managed to solve this issue by running this command

sudo apt-get install  php7.0-soap

And then restart apache

sudo service apache2 restart

Hope this may help someone.

With php5.x you can you can use

sudo apt-get install  php5-soap
4

you need to enable php soap client. Go to your php.ini file and find

extension=php_soap.dll

and remove semicolon(;) , restart your apache. check phpinfo() to see if soap is installed succcessfully.

0

It is issue with php soap.i guess php soap client is not enable on your system.

also you need check soap configuration on server:

soap path 
soap.wsdl_cache
soap.wsdl_cache_dir
soap.wsdl_cache_enabled
soap.wsdl_cache_limit
soap.wsdl_cache_ttl 

in php.init setting

0

Adding on to Haris' answer, with YUM this is

sudo yum install php70-soap
0

I had this issue too. I'm running centos 7 minimal. The php-soap package was missing from php modules. (this yum command will work as of October 2018)

Just ran

yum install php-soap

And it fixed it. :-)

And then you have to restart apache, and flush Magento cache.

SO:

apachectl restart

and Then go to backend Magento System -> Cache Management and mash the 'flush Magento cache' button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.