1

I am getting 404 error. Only home page is working only.

Can anybody tell me what could be reason for that

Thanks

  • 1
    Did you check to make sure your .htaccess is working? Try adding index.php between your domain name and page url eg domain.com/index.php/path/to/page.php – Renon Stewart Sep 23 '14 at 14:51
  • yes by adding index.php is working. what should i do – Mohit Kumar Sep 23 '14 at 16:21
2

This issue have something to do with your server not processing your .htaccess file which can be cause by many different things.

  1. Check to make sure you have .htaccess in your server root folder
  2. Check your magento setting see How to remove index.php from URLs?
  3. Your server master apache config (AllowOverride) may not setup correctly see .htaccess not working apache
|improve this answer|||||
  • root folder means where my exact setup for magento – Mohit Kumar Sep 23 '14 at 16:46
  • Where you have index.php, var, skin, app, etc – Renon Stewart Sep 23 '14 at 16:48
1

Check if mod_rewrite is enabled on server and if .htaccess is used. If you can't enable it you should disable SEO in Magento / Admin / System / Configuration / General / Web / Search Engine Optimization

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.