0

Autoload error

{$e->getMessage()}
HTML; http_response_code(500); exit(1); } $bootstrap = Bootstrap::create(BP, $_SERVER); /** @var \Magento\Framework\App\Http $app */ $app = $bootstrap->createApplication(\Magento\Framework\App\Http::class); $bootstrap->run($app); 
1
  • Please try help me
    – Rajesh
    Commented Jun 11, 2023 at 6:18

2 Answers 2

1

Check PHP version and its require modules

Create a info.php file with phpinfo() as contents and hit like this url localhost/mymagento/info.php

5
  • I am getting the blank page
    – Rajesh
    Commented Jun 12, 2023 at 7:34
  • checked version in terminal is using php -v 8.1.12
    – Rajesh
    Commented Jun 12, 2023 at 7:35
  • Link : community.magento.com/t5/Installing-Magento-2-x/…
    – MP Raj
    Commented Jun 12, 2023 at 8:15
  • Thanks, Issue is reslove after install libapache2-mod-php
    – Rajesh
    Commented Jun 12, 2023 at 9:41
  • Okay, Rajesh...
    – MP Raj
    Commented Jun 12, 2023 at 9:58
0

Can you try to access: {your_base_url}/get.php ? Does it shows the php code itself ? If yes and if you are running an apache server, you will probably miss this package: libapache2-mod-php(your wanted php version).

In my case, for PHP 8.2 running:

sudo apt-get install libapache2-mod-php8.2
sudo a2dismod php8.1
sudo a2enmod php8.2
sudo service apache2 restart

Fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.