2

we are facing an issue with Magento 2 and hopes that someone here could help.

First of all some Details; We are running our Magento on 2.4.5-p2 and PHP8.1.

Now we are facing an issue on frontend. If a customer creates an account and submits it by pressing "create account" the system is loading more than 60 secs. After that, the customer finally was created. No errors in Magento logs, it just takes a lot of time.

It's strange because on 2.4.3 we do not have this issue. Also, we do not add any custom Extensions since updating to 2.4.5. Only the PHP version was updated to 8.1.

What we already tried (solutions from other posts); added Mageplaza SMTP extension and fixed some CSP errors

Do someone have the same issue and was able to fix it?

Hopeful for any idea that could help here.

Thanks.

Update 1 I have now deactivated all third-party-plugins and it takes about 7-8 seconds to create the account. Not best timings, but much better than up to 60 seconds. I have a lot of amasty modules installed and it seems to be that the heavy loading timings coming from one of the extensions. I will test more and give a feedback with results soon.

Update 2 (final solution) Deactivating all third-party extensions helps a lot. The issue comes from one of the installed third-party extensions. Using Amasty (customerAttributes) raises the loading time up to +3-5 secs. But the real time-consuming extension was MageB2B CustomerId. While creating an account the extension also creates a unique b2b customerId. For some reason that takes too long. I already reported it to the app developer. Hopefully that a quick fix will be enrolled.

Thanks to all.

2
  • You can try disabling your existing custom extensions, even if they worked fine in 2.4.3. It might be some module compatibility error since the upgrade.
    – Cladiuss
    Jun 1, 2023 at 11:55
  • I have updated all extensions and also checked before updating, that they are compatible. But anyway i will try to deactivate all third-party plugins and try it again. I will give a feedback soon.
    – Beendeluxe
    Jun 1, 2023 at 14:49

2 Answers 2

1

To identify this issue you can follow below steps :

  1. Disable any third-party extensions and check if the slow account creation issue persists. If the problem is sorted out re-enable the extensions one by one to identify the extension causing the slowdown

  2. If you have made customizations to the account creation process, review the code changes to identify any potential bottlenecks or errors.

You can check inefficient database queries, excessive loops, or other performance issues in your custom code.

  1. Put line-by-line logs in this file and check which lines are taking much time and by this, you can identify the root cause of this issue.

vendor/magento/module-customer/Controller/Account/CreatePost.php

4
  • I will try your suggestions. But can you explain a litte bit more how to execute your 3. suggestion? I am not quite sure how to do it. Thanks.
    – Beendeluxe
    Jun 1, 2023 at 14:01
  • You can use Magento 2 logger (prnt.sc/yfpeeszHL_NW) and set some checkpoints in some random lines and check from which lines the code is taking time, I recommend this as a last option. because it is time-consuming. Jun 2, 2023 at 7:13
  • Best answer here, checking all third-party-modules was useful. I found the extension that triggered the bug here. Updated my question. Thanks
    – Beendeluxe
    Jun 5, 2023 at 10:35
  • Congratulations!! Jun 5, 2023 at 15:12
-1

Check the Magento cache should be enabled

5
  • Magento Cache is enabled...
    – Beendeluxe
    Jun 1, 2023 at 12:34
  • Check these values in PHP info memory_limit 2048M max_execution_time 18000 post_max_size 4096M max_file_uploads 2000 max_input_time 1000 max_input_vars 1000 Run command from Magento root dir. chmod -R 777 var/ generated/
    – MP Raj
    Jun 1, 2023 at 12:40
  • Here is what we have set; memory_limit = 2G max_execution_time = 18000 post_max_size = 900M max_file_uploads = 20 max_input_time = 3600 max_input_vars = 100000 I will try to increase some values and test again
    – Beendeluxe
    Jun 1, 2023 at 13:16
  • PHP changes done. Did not help. Any other suggestions?
    – Beendeluxe
    Jun 1, 2023 at 14:01
  • Check after disabling all third-party module
    – MP Raj
    Jun 5, 2023 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.