0

For the past 2 days, I haven't had any sales because Magento checkout is not processing my orders. It's giving me this error: "An error occurred on the server."

Error 400 While Receiving The Response From Payment Information.

Image error: https://scontent.fgdl2-1.fna.fbcdn.net/v/t39.30808-6/350119154_730127159120672_7714966606860123206_n.jpg?_nc_cat=100&ccb=1-7&_nc_sid=5cd70e&_nc_eui2=AeGIQ7qut0H7gWEEgB9N7Mm3q_y6kDPom-6r_LqQM-ib7mb0NDVjXdmecKYS4jdqmjw&_nc_ohc=543G_33ZIqwAX-LcVCn&_nc_ht=scontent.fgdl2-1.fna&oh=00_AfCWOHKtzf-FAxRm1QRwj6qC2hSJ59mdvhfIOb9i7bxr1w&oe=6478A642

Has anyone experienced this issue before and knows how to resolve it, or has any ideas on how I could find a solution?

Thank you very much.

4
  • The error generated from \Magento\Checkout\Model\GuestPaymentInformationManagement::savePaymentInformationAndPlaceOrder. You can see error details on system.log and exception.log at var/log folder of your project
    – Amit Bera
    May 28, 2023 at 15:02
  • 1
    Hi, thanks for the response. I have activated error logs with this command: bin/magento setup:config:set —enable-debug-logging=true php bin/magento cache:flush but nothing is showing, also i have check the logs, in the log directory, and nothing.
    – Robert
    May 28, 2023 at 16:16
  • This is my system.log cloudup.com/cNw1N4n-5u0
    – Robert
    May 28, 2023 at 17:58
  • Now is working, there was an error conexion public_html/app/etc/env.php with the 'queue' => [ 'amqp' => [
    – Robert
    May 28, 2023 at 18:55

2 Answers 2

1

Now is working, there was an error conexion public_html/app/etc/env.php

with the 'queue' => [ 'amqp' => [

0

I read the topic and went through the answers and found that you are getting the error:

'queue' => [ 'amqp' => [

I think the current workaround is that you open the env.php file at the app/etc path.

Make sure the amqp configuration is correctly defined.

Then clear the cache with the following command: php bin/magento cache:clean

Hope it helps you to solve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.