0

I updated from 2.4.4 to 2.4.6, everything seems good, except for the checkout. It seems that the customer addresses are not loaded correctly.

https://i.imgur.com/rZKZLs1.png

When I go on to the next step, the addresses are also empty: https://i.imgur.com/bBDNVSd.png

I checked the logs, nothin suspicious in there ... store is running on PHP 8.1 and compiles, upgrades and deploys without problems.

Any ideas?

Thanks!

1
  • have you find out the resolve?
    – jojo
    Dec 21, 2023 at 5:59

2 Answers 2

0

You should check for any customization to Magento_Checkout in your theme and see if it's conflicting with the updated module.

I usually do it by:

  • finding the file of interest
  • searching for the original and copying the whole thing
  • go back to the customized file, right click and "compare with clipboard".

Instead of fixing little pieces you might first try to paste the whole thing in your theme file to see if removing the customizations and having the file updated removes the problem

0

I had the exact same issue. I've traced it to some shipping modules. You are probably not running the sames ones as me however the following worked for me (until I can get the actual code fixed.

bin/magento module:disable Mageside_CanadaPostShipping Mageside_CanadaPostCustom Mageside_CanadaPostAggregation

You might try disabling shipping modules in a similar way.

Let me know if that works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.