0

I am using magento 2.4.5-p1, enterprise edition, when i tried to logged in to a customer account from adminpanel, i am unable to see the button Called "Logged in as a customer".

Please help enter image description here

After done changes, i am able to see the Login as Customer button, but still i am unable to login, it shows lie below

[![enter image description here][2]][2]

1 Answer 1

1

First check whether the following modules are enabled or not:

  • Magento_LoginAsCustomer
  • Magento_LoginAsCustomerPageCache
  • Magento_LoginAsCustomerLogging
  • Magento_LoginAsCustomerLog
  • Magento_LoginAsCustomerFrontendUi
  • Magento_LoginAsCustomerAdminUi
  • Magento_LoginAsCustomerApi
  • Magento_LoginAsCustomerWebsiteRestriction

If these are enabled, then check for the following admin configuration:

Stores > Configuration > CUSTOMERS > Login as Customer > Enable Extension

This configuration value must be Yes.

If still, it is not working, then you need to check Magento logs under {magento-document-root}/var/log folder.

7
  • Hi , now button showing
    – jaisa2
    Commented May 10, 2023 at 8:33
  • But unable to login, after the popup throws
    – jaisa2
    Commented May 10, 2023 at 8:34
  • What error are you facing? Commented May 10, 2023 at 10:32
  • I am able to redirected to the frontend and seeing the error that "Fail to get authentication data" and asked me to log in
    – jaisa2
    Commented May 10, 2023 at 12:55
  • 1
    Hi @Mohit , thans for your response, the issue is throws from the third party module that i have used thans
    – jaisa2
    Commented May 16, 2023 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.