1

i am new working with magento 2. i have build a website with magento 1 and there it was possible to install extensions very easy.

now i have learned by doing it, i have to use the SSH (i use putty) and i have to put in some command lines.

Firts i downloaded the extension zip file. i have the files and folders in my magento installation set on rights 775. then i extracted the zip file in the folder "app" and "pub" folder. then i used the next command codes in Puttys:

  • ~/public_html/bin/magento setup:upgrade

I got at the end this massege: Could not validate a connection to the OpenSearch. No alive nodes found in your cluster

  • ~/public_html/bin/magento setup:static-content:deplo y -f
  • ~/public_html/bin/magento indexer:reindex

Then when i was googling the problem i found a command line for updating the db-schema. so i give it a try. but didnt have the positive effect.

but still after trying these things i get the following massage on my website:

{"0":"Please upgrade your database: Run \"bin\/magento setup:upgrade\" from the Magento root directory.\nThe following modules are outdated:\nET_Base data: current version - none, required version - 1.0.0\nET_Theme data: current version - none, required version - 1.0.0","1":"#1 Magento\\Framework\\App\\FrontController\\Interceptor->Magento\\Framework\\Interception\\{closure}() called at [vendor\/magento\/framework\/Interception\/Interceptor.php:153]\n#2 Magento\\Framework\\App\\FrontController\\Interceptor->___callPlugins() called at [generated\/code\/Magento\/Framework\/App\/FrontController\/Interceptor.php:23]\n#3 Magento\\Framework\\App\\FrontController\\Interceptor->dispatch() called at [vendor\/magento\/framework\/App\/Http.php:116]\n#4 Magento\\Framework\\App\\Http->launch() called at [generated\/code\/Magento\/Framework\/App\/Http\/Interceptor.php:23]\n#5 Magento\\Framework\\App\\Http\\Interceptor->launch() called at [vendor\/magento\/framework\/App\/Bootstrap.php:264]\n#6 Magento\\Framework\\App\\Bootstrap->run() called at [index.php:41]\n","url":"\/admin\/","script_name":"\/index.php","report_id":"f2ef3380ba4b48f9faa3643b9ac5a2ff737d554cd16096ad4ead4ff49d816018"}

i hope someone can help me with this problem. or maybe explain me how i can install extensions in a better way. it looks like every time i google it or on youtube i seem to miss something.

thanks a lot

greets,

1
  • hi poeple, I still have problems with installing extentions. i cant figure it out why it won't work. is there someone that has some time to take a look with me and maybe explaine some things to me. maybe with is zoom connection. i am dutch and also live in the netherlands and it would be great if there are some dutch people if not it is also good :).
    – joel
    Jun 7, 2023 at 12:51

2 Answers 2

1

Please follow the steps for installation-

  1. Unzip the respective extension zip

  2. Create Vendor and module name folder inside your Magento2/app/code/ directory

  3. Move all module's files into magento root directory Magento2/app/code/Vendor/Module/ folder.

  4. Run Following Command via terminal

    php bin/magento s:up php bin/magento s:d:c php bin/magento s:s:d -f

  5. Flush the cache and reindex all.

    php bin/magento indexer:reindex php bin/magento c:f

  6. Now module is properly installed

3
  • YES! Finally I had time for it again and it finally worked! installed the extension and the background and the website still work. just strange that when I select the theme, the website no longer works. I then get the following error code that {"0":"Required parameter 'theme_dir' was not passed","1":"#1 Magento\\Framework\\View\\Design\\Fallback\\Rule\\Theme->getPatternDirs( and much more lines.
    – joel
    Apr 11, 2023 at 7:32
  • @joel thanks for your feedback Apr 12, 2023 at 12:17
  • new feedback.. i did not extract the files into main directory. so now i did and then it worked.
    – joel
    Apr 17, 2023 at 10:14
0

I think this issue was coming due to the elastic search Please restart the elastic search and try again to run same command.

And for the module installation purpose I think there is no need to put to module in the pub folder. It will automatic put needed files after running the s:s:d -f command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.