Have a site on 2.4.5, upgraded relatively recently. Upgraded to 2.4.5-1 this morning and on the front end it's now saying "Magento supports PHP 7.4.0 or later. Please read Magento System Requirements. "

Commands I ran were as follows:

php bin/magento maintenance:enable

php composer.phar require magento/product-community-edition 2.4.5-p1 --no-update

php composer.phar update --with-all-dependencies (needed to update composer.json for magento framework before this but otherwise it's the same composer.json as was already there)

php bin/magento setup:upgrade ;

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy -f;

php bin/magento cache:clean

php bin/magento cache:flush

php bin/magento indexer:reindex

php bin/magento --version - 2.4.5-p1

php bin/magento maintenance:disable

It was already on php 8.1. Looking in CPanel, it's still on 8.1. php-v gives 8.1.7. Any ideas? There were no PHP errors when all the commands were running. Apart from having to update magento framework there were no errors at all except for usualy deprecated stuff.

1 Answer 1


Turns out I just needed to re-save the page in cPanel for the 8.1 to kick back in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.