0

I have a magento 2.4.5-p1 installed. I am trying to install a custom payment module, but I don't see it in checkout. (I updated the namespaces to make it work in admin). I went through StackOverflow and tried to google but was not successful in solving the issue. I am a newbie in Magento and this is my first module. I tried to run all setup:upgrade, setup:di:compile, cache:clean, cache:flush and setup:static-content:deploy but I am not able to make my module appear. I even can't see any error message in the logs. How can I debug why my module is not showing? Any idea what the problem might be?

Thanks in advance

4
  • Do you see any log on system.log, exception.log, console log?
    – HoangHieu
    Mar 28, 2023 at 2:35
  • I see debug.log only. The exception.log and system.log are empty
    – rasevp
    Mar 28, 2023 at 6:58
  • What is the error?
    – HoangHieu
    Mar 28, 2023 at 8:00
  • There is no error. I can see other payment methods only my custom method is missing. The problem is that I don't know what the problem is :)
    – rasevp
    Mar 28, 2023 at 10:08

1 Answer 1

0

For debugging why your module is not showing

  • You have to make sure your module is enabled in app/etc/config.php
  • Make sure that you checked the module configuration in backend
    • Enabled?
    • Credential is full fill?
  • Any error log in exception.log, system.log, console log.
  • If you don't know how to use xdebug
    • Install that module on Default Magento, does it works?

About your module I can see that the module has a problem

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): The XML in file "/app/app/code/VUB/ECard/etc/payment.xml" is invalid:
Element 'method', attribute 'name': 'vubecard' is not a valid value of the atomic type 'xs:ID'.
Line: 10

Verify the XML and try again.

Exception #0 (Magento\Framework\Exception\LocalizedException): The XML in file "/app/app/code/VUB/ECard/etc/payment.xml" is invalid:
Element 'method', attribute 'name': 'vubecard' is not a valid value of the atomic type 'xs:ID'.
Line: 10

After fix the issue I can see the module's configuration in the backend.

enter image description here

4
  • Where did you find this error, please? I am testing it on a fresh installation of magento 2.4.5-p1 with developer mode enabled. When I install the module, I see it in admin and I can save the config. When I go to the checkout, the module is not there. exception.log is empty (does not exist in log).
    – rasevp
    Mar 29, 2023 at 7:12
  • Just goes to the admin you will see the error.
    – HoangHieu
    Mar 29, 2023 at 8:00
  • Many thanks, I had to restart my docker. I fixed the module name, but the problem is, that I still don't see the payment method in checkout. Would you mind helping me with the issue?
    – rasevp
    Mar 29, 2023 at 10:32
  • You can chat with me on Skype: hieu_hidro
    – HoangHieu
    Mar 29, 2023 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.