0

I have a development website that consists in a migration from 2.45 to 2.4.6. I upgraded all modules to latest version and my backend is working perfectly. However, frontend gives blank page and I get a 524 error from cloudflare. I tried to use Luma or even Blank theme, same result. As I have full access to the server, do you have any ideas or clues ? I tried to set up debugging, but nothing seems to happen :/ TIA for your help

2 Answers 2

0
  1. I would try looking the php error log of he server or the logs of magneto , system.log and exception.log. Here is a link to help you find the php error log Link
  2. Try adding to the hosts file the ip of the server and point it to the website domain, so that you bypass cloudflair. With that you will see what error you get from server on the browser.
  3. Another tip is to run bin/magento set:di:compile to see if you get some error there.

I believe from the error log of web server you will get your answer although if not , you can also disable all custom modules and again change to luma and run bin/magento setup:upgrade to see if the problem persists.

8
  • No errors on compilation. Coudflare bypassed, but same issue. NOTHING on any error log (magento / nginx / php) :(
    – JG Cabanas
    Mar 19, 2023 at 9:36
  • Have you checked if the domain targets the correct ip, check if you add a plain file in the root folder like test.php and add something like <?php echo 'test' ?> and browse it from the browser like htttps://youtdomain.com/test.php . With this you will know for sure that your request reaches your route folder. Mar 20, 2023 at 7:44
  • I can access admin URL (and everything works in admin :( ). If I create a php file I get a 404 error (from Magento) it seems routing is broken, but where to start looking for ?
    – JG Cabanas
    Mar 20, 2023 at 16:25
  • 1
    Well the 500 errors are from server, so something is wrong with the webserver or with php. Try uncommenting in the app/bootstrap.php:14 file the line #ini_set('display_errors', 1); Mar 22, 2023 at 13:28
  • Try fixing the file permissions have a look here https://www.cloudways.com/blog/magento-500-error/ Mar 23, 2023 at 14:09
0

copy vendor/magento/module-customer/view/frontend/templates/account/authentication-popup.phtml to app/design/frontend/{your-template}/Magento_Customer/templates/account/authentication-popup.phtml And remove:

<?php if ($viewModel->isGlobalScopeEnabled()): ?>
  ,
  "Magento_Customer/js/customer-global-session-loader": {}
<?php endif; ?>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.