0

We have a strange issue with adding an image to a CMS page. When we click 'insert image' in the content of the CMS page, the 'Insert File' flyout doesn't load the Media Folders Structure. We just see the whirling icon as it tries to load the folder structure. It just hangs there. I've tested the new media gallery by changing the 'Enable Old Media Gallery' to NO and this seems to work fine. However, we prefer to use the old gallery system. Please see image to demonstrate what we see. What could be the problem here please?

Andy

HERE

1
  • It could be something related to permission issues.. Kindly check in the console tab is there any error while loading page ?
    – Dotsquares
    Mar 3, 2023 at 10:01

3 Answers 3

0

It could be due to a bug or compatibility issue with your CMS version. Try upgrading your CMS to the latest version or contact the CMS support team for assistance.

0

we do see some errors but we see the same in a copy of the site which has been upgraded to 2.4.5-p1

/cms/page/edit/page_id/48/key/4245e8e1973c0db88dc5e8a0c1139a4092944195a1491220b56ebdacf6d84ec8/:1 The Content-Security-Policy directive 'frame-ancestors' does not support the source expression ''unsafe-inline'' jquery-migrate.js:23 JQMIGRATE: Migrate is installed with logging active, version 1.4.1 DevTools failed to load source map: Could not load content for http://mysite.co.uk.co.uk/static/version1677775733/adminhtml/Magento/backend/en_GB/Magento_PageBuilder/js/stage-builder.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE DevTools failed to load source map: Could not load content for http://mysite.co.uk.co.uk/static/version1677775733/adminhtml/Magento/backend/en_GB/Magento_PageBuilder/js/content-type-collection.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE DevTools failed to load source map: Could not load content for http://mysite.co.uk.co.uk/static/version1677775733/adminhtml/Magento/backend/en_GB/Magento_PageBuilder/js/content-type-factory.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE DevTools failed to load source map: Could not load content for http://mysite.co.uk.co.uk/static/version1677775733/adminhtml/Magento/backend/en_GB/Magento_PageBuilder js/config.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

Hi Harun Do you mean to Magento 2 version or the CMS module?

Thank you Andy

0

Update: I've noticed that in Firefox 'web developer tools' the media root tree loops the loading json file continiously and when copying the file link I see this.

http://mywebsite.co.uk/myadmin/cms/wysiwyg_images/treeJson/current_tree_path/d3lzaXd5Zw--/key/16b7a63a4c373b19b1416cd1f5d70a775fa03d21333c79675698d9519fc4d47c/?isAjax=true

When clicking this link (please note that I have masked our website url) I see this.

'"/var/www/vhosts/mysite.co.uk/htdocs/public_html/pub/media/htaccess" is not a valid file path'

Hope it helps you to help me. Thank you Andy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.