0

I have upgraded my site from 2.2.6 to 2.3.2 version. After upgrading through the composer command I run static-content:deploy command. I see that in pub/static my custom theme is not getting generated. I have created a theme as app/design/frontend/Swx/BaileySports.

But in pub/static/frontend only the Magento folder is created and not SWx/BaileySPorts.

How can I resolve this?

2 Answers 2

0

It sounds like the static content deployment process did not properly generate the files for your custom theme after upgrading from version 2.2.6 to 2.3.2 of Magento. There are a few possible reasons why this might have happened.

First, make sure that your custom theme is properly registered in the system. To do this, check that your theme's theme.xml file is located in the correct directory: app/design/frontend/Swx/BaileySports/theme.xml. Also, ensure that the registration.php file for your theme is properly located in the following directory: app/design/frontend/Swx/BaileySports/registration.php.

If the theme is registered correctly, the issue might be related to the static content deployment process. You can try re-deploying the static content for your custom theme using the following command:

php bin/magento setup:static-content:deploy --theme Swx/BaileySports

This command will generate the static content for your custom theme specifically. If this command fails, you may want to try clearing the static content cache first by running:

php bin/magento cache:clean

If the above steps do not resolve the issue, you may want to check the file permissions and ownership for your custom theme files, as this can sometimes cause issues with static content generation.

0

After the upgrade, The First thing you need to check the custom theme is applied correctly in the admin.

Below are the steps to check the selected theme in the admin.

In Admin, go to Content > Design > Configuration. A Design Configuration page opens. It contains a grid with the available configuration scopes. For example: enter image description here

Design Configuration page

In the configuration record corresponding to your store view, click Edit. The page with the design configuration for the selected scope opens. For example: enter image description here

The design Configuration page for a particular scope

On the Default Theme tab, in the Applied Theme drop-down, select your newly created theme.

Click Save Configuration.

If caching is enabled, clear the cache.

php bin/magento c:c

If you still facing the issue then run the static content deploy command.

php bin/magento s:s:d -f

To see your changes applied, reload the storefront pages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.